Errors within WHM

Discussion in 'General' started by GaryT, Jun 12, 2010.

  1. GaryT

    GaryT Active Member

    I installed the Litespeed withing my WHM/Cpanel. Now things are fine and I see it in plugins, things are fine there and installed great, Now when I click access web admin - I get this screen and it will not let me login atall.


    All help will be much appreciated.

    Software for server

    CSF firewall

    Thank you in advance.
    Last edited: Jun 12, 2010
  2. NiteWave

    NiteWave Administrator

    directory permission issue. what's output of
  3. GaryT

    GaryT Active Member

    root@hosting [~]# ls -ald /usr/local/lsws/admin/tmp
    drwx--x--- 2 root nobody 4096 Jun 12 07:07 /usr/local/lsws/admin/tmp/
    root@hosting [~]#

    This is response from SSH

    Im still learning so if this is a permission can you please reply with the full cmd please.
    Last edited: Jun 12, 2010
  4. NiteWave

    NiteWave Administrator

    try on ssh
  5. GaryT

    GaryT Active Member

    Nothing - I ran that - Went to Admin Web Console and got same issue - restarted litespeed - still same.
  6. NiteWave

    NiteWave Administrator

    you can temporarily try
    #chmod 777 /usr/local/lsws/admin/tmp
  7. GaryT

    GaryT Active Member

    That fixed the errors ! Now when I logon its if its trying to load but does nothing.

    I cannot click login again as boxes seem grayed out.
  8. NiteWave

    NiteWave Administrator

    see if this fix your new issue:
  9. GaryT

    GaryT Active Member

    Does not do anything, I did what you said and I got the following:

    root@hosting [/usr/local/lsws/admin/misc]# ./
    Generating key pair for web console login page, please wait ...
    Generating RSA private key, 512 bit long modulus
    e is 65537 (0x10001)
    root@hosting [/usr/local/lsws/admin/misc]#

    Here is what it does when I click login:

  10. NiteWave

    NiteWave Administrator

    please check if any meaningful info in log files:
  11. GaryT

    GaryT Active Member

    sorry for the slow reply - Internet shutdown.

    Here is the results of the command run:

    2010-06-12 07:22:33.325 [NOTICE] [**.**.*.**:62695-2#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:29:18.786 [NOTICE] [**.**.*.**:62879-2#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:30:11.309 [NOTICE] [**.**.*.**:62899-2#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:32:05.482 [NOTICE] [**.**.*.**:62937-0#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:37:48.359 [NOTICE] [**.**.*.**:63036-0#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:38:17.033 [INFO] [**.**.*.**:63045-0#_AdminVHost] ExtConn timed out while processing.
    2010-06-12 07:38:17.033 [INFO] [**.**.*.**:63045-0#_AdminVHost] connection to [/tmp/lshttpd/admin_php.sock] on request #0, confirmed, 0, associated process: 16290, $
    2010-06-12 07:38:17.033 [NOTICE] [**.**.*.**:63045-0#_AdminVHost] Suspicious request timeout, associated process: 16290, running: 1.
    2010-06-12 07:38:40.634 [NOTICE] [**.**.*.**:63054-0#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:40:45.023 [NOTICE] [**.**.*.**:63092-2#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:42:20.635 [NOTICE] [**.**.*.**:63152-2#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:45:52.286 [NOTICE] [**.**.*.**:63226-0#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-06-12 07:50:03.496 [NOTICE] [**.**.*.**:63301-2#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
  12. NiteWave

    NiteWave Administrator

    /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    this is serious -- since that's the main configuration file.
    you may need do a fresh installation.
  13. GaryT

    GaryT Active Member

  14. GaryT

    GaryT Active Member

    An uninstall - reinstall does not work either - I just tried and have exactly the same issue.
  15. NiteWave

    NiteWave Administrator

  16. GaryT

    GaryT Active Member

    Uninstalled - Installed - On installation I see a few things I dont get:

    On build match configuration I get:

    when building it also shows:

    Im totally confused.
    Last edited: Jun 13, 2010
  17. GaryT

    GaryT Active Member

    Any news on this - Host has no idea either.
  18. mistwang

    mistwang LiteSpeed Staff

    Maybe your VPS does not have enough memory to build PHP from the plugin, you may have to build PHP from command line after install LSWS. Or, let your host bump your memory limit temporarily to build matching PHP successfully.
  19. GaryT

    GaryT Active Member

    Yes there is available memory - At the time of logging in there is 1.6GB free

    I did ask the host they wanted to rebuild the cpanel there must be another way round this.

    Also it does build perfectly, Yet its the admin panel I cannot get into - When I try get in it generated the log.

    Uninstall / Install did not fix this.


    Now this is only a trial key ! Yet this still should work, See Im not going to pay if I cannot get this going, Hense the name trial.
    Last edited: Jun 21, 2010
  20. NiteWave

    NiteWave Administrator

    I experienced this error a few days back:
    vhosts looks running fine, but can't login admin console.

    in the end, I figured out it's because admin_php (which run lsws web console) is running as nobody, not lsadm. so it can't read file in /usr/local/lsws/conf and /usr/local/lsws/admin/conf which owner and group is lsadm:lsadm, permission is 700.

    when you can't login lsws admin console, please check what user admin_php is running as:

Share This Page