Failed install on Ubuntu

Discussion in 'Install/Configuration' started by mghaught, Sep 9, 2006.

  1. mghaught

    mghaught Member

    I tried installing litespeed 2.2 on Ubuntu and it failed to start up on. First, I'll say that I'm not a linux expert and am primarily a software developer. Here's the details on the error:

    /opt/lsws/bin/lswsctrl: line 43: ./lshttpd: No such file or directory
    [ERROR] Failed to start lshttpd!
    I accepted most of the defaults especially location, user and group for LiteSpeed to run under. I launched the installer via sudo such as:

    marty@projects:/opt/lsws-2.2$ sudo ./
    One issue is that the installed directory, /opt/lsws, is owned by root and the nobody user wouldn't have permissions here. So maybe I'm not running the installer correctly. My goal is to have LiteSpeed run with port 80 privileges as a system user.

    So I figured it was a permissions issue and tried to chown the lsws directories so that the nobody user could access everything. This didn't fix the issue. I still got the same error.

    I'm guessing that whatever I'm doing, I'm missing a pretty basic step. Thanks in advance for any help you can provide.

  2. xing

    xing LiteSpeed Staff


    We are here to help. =)

    If you are not root user, you need to issue "sudo lswsctrl start" instead of "lswsctrl stat". Basically in order to bind to port 80, you must have lower system rights. Once bound to the ports, litespeed will automatically downgrade itself to the user specified as part of the installation.
  3. mghaught

    mghaught Member

    Great. :)

    I went ahead and tried that with the same results:

    marty@projects:/opt$ sudo lsws/bin/lswsctrl start
    lsws/bin/lswsctrl: line 43: ./lshttpd: No such file or directory
    [ERROR] Failed to start lshttpd!
    Was the way that I did my initial install correct? Should I have run the with sudo to put into the opt dir? Note, it failed to start up at the end of the install process (which I had run as sudo).

    Anyway, I'll post the ls results of my lsws dir:

    marty@projects:/opt/lsws$ ls -l
    total 72
    drwxr-xr-x 7 nobody nogroup 4096 Sep  9 03:57 DEFAULT
    -rw-r--r-- 1 nobody root    4121 Sep  9 03:57 LICENSE
    -rw-r--r-- 1 nobody root    2214 Sep  9 03:57 LICENSE.OpenLDAP
    -rw-r--r-- 1 nobody root    6279 Sep  9 03:57 LICENSE.OpenSSL
    -rw-r--r-- 1 nobody root    3208 Sep  9 03:57 LICENSE.PHP
    -rw-r--r-- 1 nobody root       4 Sep  9 03:57 VERSION
    drwxr-xr-x 5 nobody root    4096 Sep  9 03:57 add-ons
    drwxr-xr-x 7 nobody root    4096 Sep  9 03:57 admin
    drwxr-xr-x 2 nobody nogroup 4096 Sep  9 03:57 autoupdate
    drwxr-xr-x 2 nobody root    4096 Sep  9 03:57 bin
    drwx------ 4 nobody nogroup 4096 Sep  9 03:57 conf
    drwxr-xr-x 2 nobody root    4096 Sep  9 03:57 docs
    drwxr-xr-x 2 nobody root    4096 Sep  9 03:57 fcgi-bin
    drwxr-xr-x 2 nobody root    4096 Sep  9 03:57 lib
    drwxr-xr-x 2 nobody root    4096 Sep  9 03:57 logs
    drwxr-xr-x 3 nobody root    4096 Sep  9 03:57 share
    Here's the bin dir:

    marty@projects:/opt/lsws/bin$ ls -l
    total 7220
    lrwxrwxrwx 1 nobody root      12 Sep  9 03:57 lscgid -> ./lscgid.2.2
    -r-xr-xr-x 1 nobody root   11244 Sep  9 03:57 lscgid.2.2
    lrwxrwxrwx 1 nobody root      13 Sep  9 03:57 lshttpd -> ./lshttpd.2.2
    -r-xr-xr-x 1 nobody root 7301845 Sep  9 03:57 lshttpd.2.2
    lrwxrwxrwx 1 nobody root      14 Sep  9 03:57 lswsctrl -> ./lswsctrl.2.2
    -r-xr-xr-x 1 nobody root    2232 Sep  9 03:57 lswsctrl.2.2
    -r-xr-xr-x 1 nobody root   54836 Sep  9 03:57 updateagent

  4. xing

    xing LiteSpeed Staff


    You have won the classic "install nightmare" sweepstakes. There is a ghost in the machine. =)

    I have just tested a clean intstall of lsws 2.2 into /opt/lsws using just the defaults, and everything works. My setup is Ubuntu dapper.

    sudo ./
    user: nobody
    group: nobody
    loc: /opt/lsws
    port: 80
    adminport: 7080

    Remove the /opt/lsws directory and do another clean install. Not really sure what's going on with your system. Baffling.
  5. mghaught

    mghaught Member

    Great, just what I wanted to win. :)

    Okay, what sort of permissions did you have on opt? Also, I doubt it but maybe there's a permissions issue with the untarred directory that I'm installing from. Sadly, I've tried like a half dozen clean installs. I'll keep hammering on it though.

  6. mistwang

    mistwang LiteSpeed Staff

    Please try

    cd /opt/lsws/bin
    sudo ./lswsctrl start
  7. mghaught

    mghaught Member

    Sure thing. I just did a fresh install. I will note that I did not install any of the php defaults and I did install the awstats.


    marty@projects:/opt/lsws/bin$ ls -l
    total 7220
    lrwxrwxrwx 1 root root      12 Sep 11 14:29 lscgid -> ./lscgid.2.2
    -r-sr-xr-x 1 root root   11244 Sep 11 14:29 lscgid.2.2
    lrwxrwxrwx 1 root root      13 Sep 11 14:29 lshttpd -> ./lshttpd.2.2
    -r-xr-xr-x 1 root root 7301845 Sep 11 14:29 lshttpd.2.2
    lrwxrwxrwx 1 root root      14 Sep 11 14:29 lswsctrl -> ./lswsctrl.2.2
    -r-xr-xr-x 1 root root    2232 Sep 11 14:29 lswsctrl.2.2
    -r-xr-xr-x 1 root root   54836 Sep 11 14:29 updateagent
    marty@projects:/opt/lsws/bin$ sudo ./lswsctrl start
    ./lswsctrl: line 43: ./lshttpd: No such file or directory
    [ERROR] Failed to start lshttpd!
  8. mistwang

    mistwang LiteSpeed Staff

    Maybe there is a bug in lswsctrl, which changes to another directory.
    OK. please just do

    sudo ./lshttpd
  9. mghaught

    mghaught Member

    Hmm, that didn't work as well. Here are my attempts

    marty@projects:/opt/lsws/bin$ sudo ./lshttpd
    sudo: unable to execute ./lshttpd: No such file or directory
    marty@projects:/opt/lsws/bin$ sudo ./lshttpd.2.2
    sudo: unable to execute ./lshttpd.2.2: No such file or directory
    I don't understand how it can't see the file when an ls -l shows it there with permissions to read and execute for everyone.

  10. mistwang

    mistwang LiteSpeed Staff

    That's pretty strange. Must be something wrong with your OS.
    Is "/opt" on a dedicated partition, maybe the execution is not allow for that partition.

    Maybe you should try installing lsws under /usr/local instead.
  11. mghaught

    mghaught Member

    The install at /usr/local also failed:

    /usr/local/lsws/bin/lswsctrl: line 43: ./lshttpd: No such file or directory
    [ERROR] Failed to start lshttpd!
    I'm going to ask the admins of the hosting service to look at this. FYI, this is a server running on Xen but this behavior seems really odd so I'm not sure what the deal is.

  12. mghaught

    mghaught Member

    Hi Guys,

    I had a sysadmin friend of mine check it out and he's determined that the xen server is 64 bit. I'm guessing we don't have a 64 bit version for LiteSpeed?

  13. xing

    xing LiteSpeed Staff

    LiteSpeed is 32bit but fully compatible with 64bit linux if you have installed Ubuntu's 32bit compat libraries. Note that 64bit "anything" doesn't make it faster. For LiteSpeed, going 64bit doesn't help since it's very light on memory. Though we will be releasing a 64bit version since within a 2 year span, majority of OSes will be by default, 64bit native.

    Use apt-get or snaptic and find/install 32bit compat libs.
  14. mistwang

    mistwang LiteSpeed Staff

    OK, I see.
    That's pretty strange that other system usually complain about missing 32bit libraries.
    You need to install the 32bit compatible library, ia32-libs and ia32-libs-dev to run 32bit application on 64bit Linux. Our 32bit binary works well. :)
  15. mghaught

    mghaught Member

    Thanks Guys,

    I installed ia32-libs and the web server started up. Now, I'll continue with my configuration. If I notice any other issues I'll post but hopefully I wont' have any. :)

  16. Druciak

    Druciak Member

    I have the same problem with 64 bit. I have a lot of x86_64 servers (AMD Opteron and Intel Xeon) and I have a problem with a start litespeed. I use arch x86_64 because MySQL (and Postgress) seems to work a bit faster (I don't have time to make detailed benchmarks). If I want to start litespeed I have to intall 32 bit Linux (my linux didn't want to install 32 bit libs on x86_64 arch, or I didn't know how to do it).

    Do you plan preparing litespeed on 64bit arch? Maybe it won't be faster, but it will be easier to install it on x86_64 servers.
    Last edited: Nov 17, 2006
  17. ts77

    ts77 Well-Known Member

    > If I want to start lighttpd

    this the litespeed webserver support forum.
    are you sure which webserver you are talking about?
  18. Druciak

    Druciak Member

    My stupid mistake, i'm talking about litespeed not lighttpd.
  19. mistwang

    mistwang LiteSpeed Staff

    To install the 32bit library, try
    [LEFT]sudo apt-get install ia32-libs
    64bit binary will be available for Enterprise edition in our upcoming 3.0 release.
  20. bdm

    bdm Member

    Irregularity in LSWS-3.0RC2 on Ubuntu Edgy

    I had been using LSWS-2.2 up until last week and had been required to apply the remedy;

    sudo apt-get install ia32-libs

    I have since migrated to LSWS-3.0RC2 and have had no further issue with this until yesterday. Rebuilding my Slice daily, I was surprised when LSWS-3.0RC2 failed with the error;

    /opt/lsws/bin/lswsctrl: 140: ./lshttpd: not found
    [ERROR] Failed to start lshttpd!

    After using the above solution of the ia32-libs, I reinstalled LSWS-3.0RC2 and it worked fine. Thought I would mention this anomaly.

    Confirmation: rebuilt Slice from scratch this morning, exact same issue, exact same solution but fixed.

Share This Page