Gzip Compression


I cannot enable gzip compression. I have checked tutorials how enable it, although it appeared already enabled on LS configuration, but it still does not work. Can anyone help?



Staff member
You's better providing some details with example and also what you did in details:

For example:
"I cannot enable gzip compression"-> what did you do?
" I have checked tutorials " -> which Rutorials? Link to it?
"it appeared already enabled on LS configuration "_> better show a screenshot for it.
"but it still does not work " -> How did you check? What's shown in the headers(better screenshot to show full headers? can you provide example URL which is not working?

Without such details, no one knows what your problem was, what 's wrong with your configuration, Which steps you have missed...

The following could be a good example with detailed steps 1,2,3,4 ... with URL and action to be taken.

Example bug report:

Got a report for Wordpress multisite with mod_userdir issue from a customer and reproduced on a test server.
Issue: if mod_userdir in use (site access as http://serverIP/~username/ ) and with wordpress multisite setup the second site fails loading physical content (css/js/media files). Same setup with same .htaccess works with pure apache.

http://xxx.xxx.xxx.xxx/~bbtest1/ - a first site, works Ok
http://xxx.xxx.xxx.xxx/~bbtest1/sitea/ - a second site, from WP network, has broken css/js

I am attaching debug log for above 'site' at the attachment.

Issue could be easily reproduced on any test environment:
1. create user, get access to it over userdir as http://serverIP/~username/
2. install wordpress into DocumentRoot
3. enable WP multisite, open wp-config.php and add:
define( 'WP_ALLOW_MULTISITE', true );
4. login to wp as admin > Tools > Network Setup , enable sub-directories, click Install
5. insert generated code (Multisite related) into wp-config.php and into .htaccess (replace)
6. login to wp as admin again
7. create another site from My Sites > Network Admin > Sites
8. try accessing that newly created site as http://serverIP/~username/newsite/
Hi Pong,

You are definitely right about my poor expIanation and I am sorry about that. I will make sure next time to be more accurate.

However I think NiteWave replied to me mistakenly in another post by providing me the following links

"please refer

most likely brotli is used instead of gzip"

And I have found out that gzip is enabled and that it is actually used brotli instead of gzip.



Staff member
Glad you have found the solution. Yes, LiteSpeed will automatically use brotli compression, hence you may see "Content-Encoding: br" instead of "Content-Encoding:gzip" in the header.