Discussion in 'Bug Reports' started by Dani, Nov 29, 2005.

  1. Dani

    Dani Well-Known Member


    I'm having some problems with gzip. When enabled some files give me random "The page cannot be displayed". I had this with my old config on apache but it got fixed using mod_gzip_minimum_file_size 5098
    but when I use it in litespeed tuning "Min Static File Size (bytes) 5098" I still get the same problem.

    This problem is IE only! FF and the rest work fine, lswl dosn't show any errors on this so I can't see much of what's going on.

    And another bug that I think excists is when yu login to the web server config with Firefox the session never updates itself. if the Session Timeout is 300sec then you will get logged out in 300 seconds wether you are idle or not.

    I was also wondering if the promt of the web admin login 'name' could be changed? When it shows now it says "..... lite speed webadmin 1133...' I guess its a unix timestamp? FF dosn't remember that promt and can never save the password, which is annoying since it asks for it alot of times...

    I also discovered a hole when playing around with the timeout. When i click on log off I come to:
    Thank You for Using LiteSpeed Webserver
    You have successfully logged off from administration center.
    For your security, we recommend you close your browser.
    Or you can log on again from here.

    I then click on 'log on again' press escape and get to:
    "You must enter a valid login ID and password to access this site"

    So far so good... But then I hit F5 and tada I'm logged in as admin =) Donno how or why but it's in and I can change everything withuot any problems..
  2. mistwang

    mistwang LiteSpeed Staff

    Is the gzip probem for dynamic content or static content?

    We will double check the problem related to admin interface.
  3. Dani

    Dani Well-Known Member

    It's dynamic content...

    the admin problem seems to just be in FF if that will help. I'll debug it some more since I'll login everyday. But it if you could fix the problem with saving the password dialog. eliminating that unix timestamp would do since I'm not sure it does any good there anyway.
  4. Dani

    Dani Well-Known Member

    i just debugged but couldnt find much info other than gzip dosn't zip files other than .html, i've pasted the log at the bottom..

    http://www.whatsmyip.org/mod_gzip_test gives :-------------------

    /index.php is not gzipped
    Page Size: 8 K
    Size if Gzipped: 2 K
    Potential Savings: 75%

    /index.html is gzipped
    Original Size: 2 K
    Gzipped Size: 1 K
    Data Savings: 50%

    /index.htm is not gzipped
    Page Size: 1 K
    Size if Gzipped: 1 K
    Potential Savings: 0%


    GZIP Compression Tuning Edit
    Enable Compression Yes
    Enable Dynamic Compression Yes
    Compression Level (Dynamic Content) 6
    Compressible Types text/*

    Enable GZIP Yes

    here is what I get from the debug when I alone debugged the login that fails on my site:

    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0] HttpConnection::eek:nReadEx(), state: 0!
    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0] readToHeaderBuf().
    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0] Read from client: 785
    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0] processHeader() return 0, header state: 3.
    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0#www.mysite.com] New request:
    Method=[POST], URI=[/login/clogin.php],
    Content Length=52
    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0#www.mysite.com] Read Request Body!
    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0#www.mysite.com] Finshed request body 52 bytes!
    2005-11-29 21:36:53.131 [DEBUG] [myip:46039-0#www.mysite.com] Find handler [phpLsapi] for [.php]
    2005-11-29 21:36:53.132 [DEBUG] [myip:46039-0#www.mysite.com] processContextPath() return 0
    2005-11-29 21:36:53.132 [DEBUG] [myip:46039-0#www.mysite.com] run lsapi processor.
    2005-11-29 21:36:53.132 [DEBUG] [uds://tmp/lshttpd/lsphp.sock] connection available!
    2005-11-29 21:36:53.132 [DEBUG] [uds://tmp/lshttpd/lsphp.sock] request [myip:46039-0#www.mysite.com:lsapi] is assigned with connection!
    2005-11-29 21:36:53.132 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] ExtConn::continueRead()
    2005-11-29 21:36:53.132 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] ExtConn::suspendWrite()
    2005-11-29 21:36:53.132 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] processNewReq() return 0.
    2005-11-29 21:36:53.132 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] readToHeaderBuf() return 0.
    2005-11-29 21:36:53.133 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] ExtConn::eek:nRead()
    2005-11-29 21:36:53.133 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] LsapiConn::doRead()
    2005-11-29 21:36:54.862 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] ExtConn::eek:nRead()
    2005-11-29 21:36:54.862 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] LsapiConn::doRead()
    2005-11-29 21:36:54.862 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] GZIP response body!
    2005-11-29 21:36:54.862 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] [EXT] EndResponse( endCode=0, protocolStatus=0 )
    2005-11-29 21:36:54.862 [DEBUG] [uds://tmp/lshttpd/lsphp.sock] add recycled connection to connection pool!
    2005-11-29 21:36:54.862 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] Written to client: 473
    2005-11-29 21:36:54.862 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] HttpConnection::flush()!
    2005-11-29 21:36:54.862 [DEBUG] [myip:46039-0#www.mysite.com:lsapi] HttpConnection::nextRequest()!
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1] HttpConnection::eek:nReadEx(), state: 0!
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1] readToHeaderBuf().
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1] Read from client: 643
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1] processHeader() return 0, header state: 3.
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1#www.mysite.com] New request:
    Method=[GET], URI=[/indexx.php],
    Content Length=0
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1#www.mysite.com] Find handler [phpLsapi] for [.php]
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1#www.mysite.com] processContextPath() return 0
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1#www.mysite.com] run lsapi processor.
    2005-11-29 21:36:55.062 [DEBUG] [uds://tmp/lshttpd/lsphp.sock] connection available!
    2005-11-29 21:36:55.062 [DEBUG] [uds://tmp/lshttpd/lsphp.sock] request [myip:46039-1#www.mysite.com:lsapi] is assigned with connection!
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] ExtConn::continueRead()
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] ExtConn::suspendWrite()
    2005-11-29 21:36:55.062 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] processNewReq() return 0.
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] readToHeaderBuf() return 0.
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] ExtConn::eek:nRead()
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] LsapiConn::doRead()
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] ExtConn::eek:nRead()
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] LsapiConn::doRead()
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] GZIP response body!
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] use CHUNKED encoding!
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] Written to client: 352
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] HttpIOLink::suspendWrite()...
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] [EXT] EndResponse( endCode=0, protocolStatus=0 )
    2005-11-29 21:36:55.063 [DEBUG] [uds://tmp/lshttpd/lsphp.sock] add recycled connection to connection pool!
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] HttpIOLink::continueWrite()...
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] write resumed!
    2005-11-29 21:36:55.063 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] Written to client: 843
    2005-11-29 21:36:55.064 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] Written to client: 5
    2005-11-29 21:36:55.064 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] HttpConnection::flush()!
    2005-11-29 21:36:55.064 [DEBUG] [myip:46039-1#www.mysite.com:lsapi] HttpConnection::nextRequest()!
    2005-11-29 21:36:57.000 [DEBUG] Failed to execute 'mpstat' command: No such file or directory
    2005-11-29 21:37:00.100 [DEBUG] [myip:46039-2] Close socket ...
  5. mistwang

    mistwang LiteSpeed Staff

    Log shows that response has been gzipped for the two php requests.
    And the gzip size limit is just for static files, have no effect on dynamic contents.
  6. Dani

    Dani Well-Known Member

    ok but afterwards when it logs in and is supposed to forward you onto another page it says this page could not be found.. that's where the debug ends and stops..

    btw what's:

    2005-11-29 21:36:57.000 [DEBUG] Failed to execute 'mpstat' command: No such file or directory

    ? I didn't enable awstats..
  7. mistwang

    mistwang LiteSpeed Staff

    So, what exactly is the issue? I am lost. :?: :)

    The log should show you which file is missing, and you can take action accordingly.

    You can ignore that message, it is for the real time statistic.
  8. Dani

    Dani Well-Known Member

    hehe ok from the top.

    site works fine with gzip OFF.

    site works fine with gzip ON AND dynamic compression OFF

    site dosn't process the login on the page as it should with gzip ON AND dynamic compression ON

    the log i pasted is the one with both ON. The procedure is a simple login to a page which if correct pass sends you to next page... but instead shows 'this page could not be shown' for some reason.
  9. mistwang

    mistwang LiteSpeed Staff

    Can you please create a simple test script for us to reproduce it in our lab?
  10. xing

    xing LiteSpeed Staff

    You would encounter the above error if you ENABLE dynammic compression on litespeed AND the php app has gzip output bufferting internally enabled. Please make sure you php.ini has gzip output buffering off and also with your app config, such as vbulletin.
  11. mistwang

    mistwang LiteSpeed Staff

    Thank you! Xing, I will double check, see if I can figure out a work around. :)
  12. Dani

    Dani Well-Known Member

    oh but where is it located in the php.ini? I only have eaccelerator at the bottom that has something to do with the 'compression' of any kind...
  13. mistwang

    mistwang LiteSpeed Staff

    I run some tests on this, but every thing looks fine. Will try more.

Share This Page