htaccess is ignored?

#1
Hello,

Tried search here but no luck, perhaps asked with wrong keywords.

Have trial version installed, moving website from apache. Found that .htaccess is ignored completely: added "blablah" at the very top of the file and see no errors either in vhost logs or the server log at all.

Vhost=>general=>HT access set to Allow Override: options and Access File Name .htaccess

Vhost=>rewrite=>Rewrite Control:
Code:
Enable Rewrite: yes
Log Level 9
The only log message higher than 'notice' in the server log is 'Warning: Redirect destination does not specified, ignore!' but it can be related to another vhost, have no idea how to check.

So, how can I enable htaccess parsing?

Also, could anyone confirm htaccess will work without modifications assuming it works on apache? It's quite complicated and I hope drop-in apache replacement can handle it well.

Thank you.
 
Last edited by a moderator:
#4
Tried to add to "Apache Style Configurations":
Code:
<Directory  /path/to/docroot/>
 AllowOverride All
</Directory>
But see those errors:
Code:
[/usr/local/lsws/conf/vhosts/www.domain.com.xml:1] Failed to add <Directory context: /path/to/docroot/
Could anyone advise, please?
 
Last edited by a moderator:
#7
In case anyone else gets stuck, I had to do a "graceful restart" of litespeed after changing the .htaccess file.

1.) Change Permalinks
2.) Saving / updating is broken
3.) Restart litespeed
4.) Saving / updating works

I'm unsure if there is a setting that allows .htaccess changes to take effect without a restart but I'd love to know.

OpenLiteSpeed Version 1.4.44
 

Pong

Well-Known Member
Staff member
#8
this forum is for Litespeed enterprise. Openlitespeed issue should be at forum.openlitespeed.org.
You are correct. There is no restart need if any change in .htaccess for LiteSpeed Enterprise, however, you will need to restart OpenLiteSpeed anytime you make a change to .htaccess to make the change effective.
 
Top