Index Issue

Discussion in 'Install/Configuration' started by DNSFusion, Jul 8, 2004.

  1. DNSFusion

    DNSFusion New Member

    Ok, so maybe its me getting used to Litespeed, but i am having problems setting the index file.

    I currently have it set to index.php, and nothing else.

    I have an index.php file in my html/ directory but when i browse to it does not display the default index. It will only display the page when i go to

    Any ideas?

  2. mistwang

    mistwang LiteSpeed Staff

    Sorry for the late reply, did not notice this earilier.

    Which level of index configuration is set at? Server or virtual host? What is the value of "use server setting" at virtual host level?

    I believe the index page will work properly if you set those configurations properly.

    Best regards,
  3. haynest

    haynest New Member



    I have manged to install Litespeed and have gotten it to work with mysql. I ended up having to get the mysql.defaut_socket setting out of my.cnf and adding it to the php.ini

    All seems to be working quite well.

    I am interested in speeding up a learning management system on a server that is working too hard. The next step will be to install the two servers side by side and check page load times.

    I seem to be unable to get the index.php as the index file. I have index.php in the server -> general -> general settings. I also added index.php everywhere I could find the index file option like in virtual hosts.

    I am doing something wrong here.

    http://myserver/moodle gives an error.

    http://myserver/moodle/index.php works.

    Got any suggestions?

    Regards... Tom
  4. mistwang

    mistwang LiteSpeed Staff

    Is there any rewrite rules or context definitions in the configuration, how about http://myserver/ , just add an index.php to the document root of your server, see if it works.
    Have you ever tried: http://myserver/moddle/ ?

    Best regards,
  5. haynest

    haynest New Member



    I tried the trailing slash, and it still does not snag the index.php file. I had a comma separated list with index.html in there too, but for testing purposes, I took out everthing _but_ index.php, and it is still not finding it.

    I copied the phpinfo.php to index.php, and reloaded. It loads index.html even when I reload and disable cache.

    I am doing something wrong here.

    I appreciate your responding so quickly.

    edit- I rebooted the server and it now works

    Something in my process was faulty, but it is working, and I appreciate the help. -edit

    Regards... Tom
  6. mistwang

    mistwang LiteSpeed Staff

    What you need probably is just a lsws restart from command line, there is a bug in 2.0RC4 which cause the "restart", "reload" stop functioning once you reload the configuration file from the web admin interface, it will be fixed soon in next release. In the mean time, just use "restart" to apply your changes from the web interface. :)

Share This Page