Installation 5.2 failed

Discussion in 'Install/Configuration' started by mahdi8492, Aug 24, 2017.

  1. mahdi8492

    mahdi8492 New Member

    hello

    when we try to install v5.2 , error :
    LiteSpeed WHM Plugin Installed Successfully.
    ==============================================
    cp: cannot stat `/usr/local/lsws/autoupdate/lsws-5.2/bin/lshttpd': No such file or directory
    chown: cannot access `/usr/local/lsws/bin/lshttpd.5.2': No such file or directory
    chmod: cannot access `/usr/local/lsws/bin/lshttpd.5.2': No such file or directory
    mv: cannot stat `/usr/local/lsws/modules': No such file or directory
    [OK] The startup script has been successfully installed!
    Restarting LSWS
    [ERROR] Cannot find /usr/local/lsws/bin/litespeed
    Done


    when i check archve : https://www.litespeedtech.com/packages/5.0/lsws-5.2-ent-x86_64-linux.tar.gz
    bin/lshttpd ->>> Not Found


    how to fix ?
     
  2. mistwang

    mistwang LiteSpeed Staff

    It is a problem on our side, please try again.
     
  3. Crazy Serb

    Crazy Serb Member

    I installed 5.2 just fine, but this Upgrade to 5.2.1 isn't going anywhere... Upgrade from WHM/cPanel just results in page reload.
     
  4. Crazy Serb

    Crazy Serb Member

    Actually this happens now on two separate servers... if I installed v5.2 before the v5.2.1 was pushed out, I get stuck in a loop no matter what I press (switch to 5.1.7, upgrade to 5.2.1, etc) - the buttons don't do anything anymore, they just refresh the page.

    HELP!
     
  5. NiteWave

    NiteWave Administrator

    not sure what exactly happen on your servers.
    please try:
    1. rm -rf /usr/local/lsws/autoupdate/*
    2. /usr/local/lsws/admin/misc/lsup.sh -f -v 5.2.1
    to see if the issue will be gone.
     
  6. Crazy Serb

    Crazy Serb Member

    Well that worked... on all 3 servers (all 3 different from one another, and on different providers).

    Interesting. Bookmarking this thread, just in case it happens again in future.

    Thank you.
     
  7. Michael A

    Michael A Administrator Staff Member

    Hello Crazy Serb,

    The reload problem when trying to update is tied to some missing JavaScript in older version of our WHM plugin. This should be fixed in the version packaged with 5.2.1 (ver 2.2.2).

    If you run into this issue on any other server, update using lsup instead. My appollogies for any inconvenience this might cause.

    Regards,
    -Michael
     
  8. mobisuper

    mobisuper Member

    Just as an fyi, I had the same issue: trying to update through WHM just reloaded the page. I found that updating through the LS Web Console worked without problems. Not sure if that will fix future updates through WHM back again, but at least now I have 5.2.1
     
    NiteWave likes this.
  9. Michael A

    Michael A Administrator Staff Member

    Hi mobisuper,

    LSWS 5.2.1 and up should be back to normal.

    Thank you for the feedback,
    -Michael
     

Share This Page