Installing ACPu via PECL cPanel/EAV4 not working

ffeingol

Well-Known Member
#1
We have a server with cPanel/EAV4 and LSWS. We installed APCu via PECL (from WHM) for PHP 7.2. If I run the PHP 7.2 from command line with -i parameter, I can see that APCu is installed and active. When I create a phpinfo() page on a site running PHP 7.2 I don't see APCu.

I can see that the appropriate ini files are getting parsed/included from the phpinfo() page.

Any and all thoughts on this will be greatly appreciated.
 

ffeingol

Well-Known Member
#6
Yea, it's just really odd. lsphp -i as the user shows APCu installed. Other sites running PHP 7.2 show it in a phpinfo page. I don't see a php.ini or .user.ini etc. that would be removing the module.
 

ffeingol

Well-Known Member
#9
One other interesting note. I have a phpinfo page on two sites on this VPS that both use EA PHP 7.2. The build date (2nd item in phpinfo) is different between the two sites. That seems somewhat impossible as there is only one EA PHP 7.2.

in /tmp/lshttpd the APVH_###_Suea-php72.sock files have very different dates (today vs March 2nd).

Not sure if that sheds any light on anything.
 
#11
To follow up (as others I'm sure will run into this) We ran "Restart Detached PHP Processes." from within the WHM LSWS plugin. Put in a request to cPanel to do that automatically for php.ini changes, PECL /PEAR module installs etc.

Thanks again for the guidance.
 
Top