Installing memcache

Discussion in 'Install/Configuration' started by gas, Mar 1, 2014.

  1. gas

    gas Member

    Hi all!
    I'm really liking my trial weeks of litespeed...the website is really faster.

    I recompiled latest version of php via litespeed control panel, flagging the option to install memcache.

    After a couple of graceful restarts, I can't still find it... please check my php info page:

    Any idea why?

  2. NiteWave

    NiteWave Administrator

    to php.ini
  3. gas

    gas Member

    thanks. where can I find this file exactly?
  4. NiteWave

    NiteWave Administrator

    open a phpinfo page in browser, search "extension_dir"
  5. gas

    gas Member

    Thanks, I meant php.ini and I found it just 2 min later =)
  6. gas

    gas Member

    Question: my phpinfo file gives me this path for the php.ini file (so I can modify it to add memcached)

    Configuration File (php.ini) Path/usr/local/lsws/lsphp5/lib
    Loaded Configuration File(none)
    Scan this dir for additional .ini files(none)
    Additional .ini files parsed(none)

    If I try to ftp or ssh this file, I can't find it... any idea why?
  7. NiteWave

    NiteWave Administrator

    because php.ini not exist yet --- you can create a new one

    -- or --
    there are 2 php.ini files within a php package:

    just copy and rename one of them to /usr/local/lsws/lsphp5/lib/php.ini
  8. gas

    gas Member

    Wow! We are almost there!
    Finally I was able to add a php.ini file, that is woking (I changed max file size and it worked).

    Only problem is, when I add , the extension is not loading even if it's in the extension directory (I checked). Every time I did a graceful restart.

    I tried with xcache, and it loaded correctly.... any idea? Thanks

Share This Page