Language string missing when module set as ESI

#1
Hi,
I have a module that shows the "recently viewed" products from virtuemart, but when i put this module under ESI, whether in public or private mode.
The languages strings are lost, I think this is because this module use a plugin from the framework of my template itself, and those languages string (.ini files) are under the "administrator/language" folder.
So what I've done is simply to put an override for those "lost" strings in the frontend side language folder.

But do you think something could be done by the side of the litespeed cache plugin code for this issue ?
Or something else ?

Thanks for this great plugin in any case.

EDIT: Seems a little worse than I thought, once the module is cached, and set to private or public or nocache,
I get a 404 just because component not found.
Seems because if there's no recently viewed product, the ESI cache try to call the module anyway.
No fix at this time

EDIT2: ok, the fix at this time is to use "Advanced Module Manager" from R.L to have the "Hide if empty" option on the module, and set it to ESI with nocache option. Or is it related to JCH ????
But I am open to other solutions, because this module does not benefit from the cache.

EDIT3: Nope, still 404 despite the module is cached or nocache when the visitor has not yet seen a product recently viewed.
 
Last edited:

Wuhua Chen

Active Member
Staff member
#2
#3
thanks
It does not work correctly, this time I have no more 404, but on the other hand the design of the page is very disturbed when I choose the plugin processing option activated on the module under ESI.

I will open a ticket ASAP
Regards
 
Top