libjpeg.(a|so) not found. But it's there!

Discussion in 'PHP' started by J.T., Jul 24, 2010.

  1. J.T.

    J.T. Well-Known Member

    Hi,

    Trying to compile PHP 5.2.13 on Centos 5.4.

    Two contradicting lines highlighted.

    It mentions opt as I tried this bug workaround:

    http://bugs.php.net/bug.php?id=33685&edit=1

    libjpeg.so is actually in /usr/lib and even if I say --with-jpeg --enable-jpg --with-jpeg-dir=/usr or even with-jpeg-dir=/usr/lib it just won't compile/configure.

    Previous PHP compiles on similar OSes went just fine.

    How can it first detect it's in the folder and subsequently think it's not?

    # yum install jpeg* says it's installed and latest already...

    in /usr/lib where /opt/lib is symlinked to for good measure:

    libjpeg.so
    libjpeg.so.62
    libjpeg.so.62.0.0

    One curiosity I noticed is that despite compiling PHP 5.2.13 on Step 3: Preparing for building PHP 5.2.13 Binary it says:

    Referencing 5.3.1

    This is latest LSWS v 4.0.15 Std on a dev VM.

    Any ideas? Thanks.
     
  2. J.T.

    J.T. Well-Known Member

    Is it worth me trying this in v16? Any ideas? Thanks.
     
  3. NiteWave

    NiteWave Administrator

    yes, you can try 4.0.16
    at least it should wget php-litespeed-5.4.tgz not php-litespeed-5.3.1.tgz
     
  4. J.T.

    J.T. Well-Known Member

    So even when I want to compile PHP 5.2.13 it'll always grab the latest PHP available?
     
  5. J.T.

    J.T. Well-Known Member

    Still ge tthe same message now I finally tried it with 4.0.16. Both PHP 4.2.13 and 14 don't work, same error. "configure: error: libjpeg.(a|so) not found"

    I said earlier it's Centos 5.4 but I believe it's actually 5.5 kernel 2.6.18-194.8.1.el5

    It does extract php-litespeed-5.4.tgz as you expected.

    Any ideas?
     
  6. NiteWave

    NiteWave Administrator

    maybe your server lack of header files of jpeg
    to build with php, need
    #yum install libjpeg-devel.i386
    or
    #yum install libjpeg-devel.x86_64
    i.e., package with -devel in package name.

    run
    to check if the -devel- package installed or not.
     

Share This Page