Lightspeed lagging after server move

Discussion in 'Install/Configuration' started by ChannelCat, May 3, 2005.

  1. ChannelCat

    ChannelCat Member

    After moving to a freeBSD with dual opterons (far more powerful than the last server) and switching to enterprise trial (using kqueue), litespeed now randomly sucks up CPU usage and resources, and lags terribly. I'm not sure if this is an issue with my kernel compile, or litespeed itself. I tried lighttpd, and it ran fine for about 10 minutes, then topped out at 100% cpu usage and crashed. Apache runs fine, but i can't control the amount of php processes running. I would like to use litespeed because in the past it has been great, so any help would be very much appreciated!

    I also noticed this in the error logs:
    2005-05-02 10:16:33.649 ERROR HttpListener::acceptConnection(): [] can't accept:Invalid argument!
    2005-05-02 10:53:59.008 ERROR Unexpected error inside event loop: Bad file descriptor

  2. mistwang

    mistwang LiteSpeed Staff

    I think it might be related to kqueue.
    Please switch to "poll" see if it help, "kqueue" has not been heavily tested in production yet. Please keep us posted. Thanks. :)

    We will check the error.
  3. ChannelCat

    ChannelCat Member

    Sure thing. I'll report how that goes after an hour or so of live testing. Thanks for your help 8)

  4. mistwang

    mistwang LiteSpeed Staff

    Are you using 64 bits FreeBSD with 32 Bits compatible layer enabled or 32 bits FreeBSD?
    Have you tried LiteSpeed again yet? Apache is pretty slow on your new server. ;-)
    Any plan to use litespeed on your image server? thttpd is not good for large image server, take a look at new customer testimony on the frontpage from :)

Share This Page