LiteSpeed + 1500 Domains + FrontPage = ?

Discussion in 'Bug Reports' started by vivek, Feb 19, 2008.

  1. vivek

    vivek Well-Known Member


    Just a simple issue with me.
    I have litespeed enterprise version running since 20 days.

    We have FrontPage extension working fine with litespeed and I think that is causing a delay when litespeed starts/restarts

    When I issue service lsws restart , or when httpd.conf changes, litespeed is restarting and it takes around 1 minutes to start fully.

    All websites are not loading for 1 minutes.

    I have cPanel running on CentOS, and around 1516 domains on a Xeon Dual core ,2GB RAM.

    I checked the log and I found the litespeed is searching for FrontPage extensions and that is causing a delay

    someting like this

    2008-02-19 00:49:26.579 [NOTICE] [FrontPage] /home/siasindi/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:27.056 [NOTICE] [FrontPage] /home/sistin/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:28.749 [NOTICE] [FrontPage] /home/slutvide/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:29.045 [NOTICE] [FrontPage] /home/smash/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:29.302 [NOTICE] [FrontPage] /home/southcin/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:30.097 [NOTICE] [FrontPage] /home/squadm/public_html/_vti_inf.html is writable by group or others!
    2008-02-19 00:49:31.273 [NOTICE] [FrontPage] /home/status/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:31.615 [NOTICE] [FrontPage] /home/stimuli/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:31.660 [NOTICE] [FrontPage] /home/stizoula/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:33.637 [NOTICE] [FrontPage] /home/sunrise/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:33.751 [NOTICE] [FrontPage] /home/support/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:33.946 [NOTICE] [FrontPage] /home/sureent/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:34.250 [NOTICE] [FrontPage] /home/svnwei/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:34.329 [NOTICE] [FrontPage] /home/swamiraj/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:34.406 [NOTICE] [FrontPage] /home/swamybin/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:34.461 [NOTICE] [FrontPage] /home/swamyboo/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:34.524 [NOTICE] [FrontPage] /home/t2sgloba/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:35.226 [NOTICE] [FrontPage] /home/tanmoy/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:35.285 [NOTICE] [FrontPage] /home/tech9n8t/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:35.388 [NOTICE] [FrontPage] /home/techmant/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:35.675 [NOTICE] [FrontPage] /home/tehrancy/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:36.449 [NOTICE] [FrontPage] /home/thegalax/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:36.549 [NOTICE] [FrontPage] /home/thegolf/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:36.698 [NOTICE] [FrontPage] /home/thehouse/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:36.781 [NOTICE] [FrontPage] /home/thehunts/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:37.050 [NOTICE] [FrontPage] /home/therocke/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:37.109 [NOTICE] [FrontPage] /home/theserv/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:37.921 [NOTICE] [FrontPage] /home/tipsterh/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:38.050 [NOTICE] [FrontPage] /home/tking/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:38.106 [NOTICE] [FrontPage] /home/toadsvid/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:38.163 [NOTICE] [FrontPage] /home/toilet54/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:38.403 [NOTICE] [FrontPage] /home/tpwong/public_html/_vti_inf.html is writable by group or others!
    2008-02-19 00:49:38.439 [NOTICE] [FrontPage] /home/trades4c/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:38.671 [NOTICE] [FrontPage] /home/tritech2/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:39.084 [NOTICE] [FrontPage] /home/truthwor/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:39.118 [NOTICE] [FrontPage] /home/tscujj/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:39.849 [NOTICE] [FrontPage] /home/uberpcge/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:39.915 [NOTICE] [FrontPage] /home/ubxindia/public_html/_vti_bin/_vti_aut is missing!
    2008-02-19 00:49:40.357 [NOTICE] [FrontPage] /home/urdothos/public_html/_vti_bin/_vti_aut is missing!

    etc etc

    If the total domains are 100-500 then it will be ok, but I am having 1500+ domains. Also, litespeed is restarting at least 5-10 times a day because of httpd.conf change or manual restart

    Is there any way, we can avaoid the frontpage files checking ?

    Also, I have noticed another line too which is the second most common in error.log

    2008-02-19 00:58:13.873 [INFO] [HTAccess] Configuration file [/home/admin070/public_html/chat/.htaccess] changed.
    2008-02-19 00:58:13.873 [INFO] [HTAccess] Updating configuration from [/home/admin070/public_html/chat/.htaccess]
    2008-02-19 00:58:14.597 [INFO] [HTAccess] Updating configuration from [/home/prohost3/public_html/.htaccess]
    2008-02-19 00:58:19.591 [INFO] [HTAccess] Updating configuration from [/home/secret/public_html/.htaccess]
    2008-02-19 00:58:20.093 [INFO] [HTAccess] Configuration file [/home/admin070/public_html/chat/.htaccess] changed.
    2008-02-19 00:58:20.093 [INFO] [HTAccess] Updating configuration from [/home/admin070/public_html/chat/.htaccess]
    2008-02-19 00:58:21.369 [INFO] [HTAccess] Updating configuration from [/home/rock/public_html/.htaccess]

    updating config .httaccess.

    I dont think .httaccess is changing every second or every minute.

    Is there any way , we can speed up the litespeed restarts like apache ?

  2. mistwang

    mistwang LiteSpeed Staff

    OK, we will try to improve this in the 3.3.5 release.
  3. vivek

    vivek Well-Known Member

    Thank you
    When you guys release the next version ? Any date ?
  4. mistwang

    mistwang LiteSpeed Staff

    updated 3.3.5 release package has been uploaded, you need to upgrade to it manually.
    Just change the version number in the download link to get it. It should fix the performance issue with frontpage.
    A new configuration option has been added in the Apache configuration section, to explicitly turn on Frontpage support.
  5. vivek

    vivek Well-Known Member

    Thank you for the update. The frongpage error is no longer showing there. But litespeed is starting slow.

    [root@monster logs]# tail -f error.log
    2008-02-19 20:21:20.917 [NOTICE] [AutoRestarter] child process with pid=6351 exited with status=0!
    2008-02-19 20:21:20.917 [NOTICE] [PID:6331] Server Stopped!
    2008-02-19 20:21:23.692 [NOTICE] [AutoRestarter] new child process with pid=6961 is forked!
    2008-02-19 20:21:23.735 [NOTICE] [child: 6961] Successfully change current user to nobody
    2008-02-19 20:21:23.735 [NOTICE] [Child: 6961] Core dump is enabled.
    2008-02-19 20:21:23.759 [ERROR] [config] Path for public folder of Rails application is invalid: /home/jagbir/public_html/test/public/
    2008-02-19 20:21:23.760 [NOTICE] [Child: 6961] Setup swapping space...
    2008-02-19 20:21:23.760 [NOTICE] [Child: 6961] LiteSpeed/3.3.5 Enterprise starts successfully!
    2008-02-19 20:21:24.117 [NOTICE] [AutoUpdate] Checking for new releases...
    2008-02-19 20:21:24.328 [INFO] [AutoUpdate] No new update.

    Sorry to say, litespeed is not starting even after 5 minutes
    Last edited: Feb 20, 2008
  6. vivek

    vivek Well-Known Member

    LiteSpeed 3.3.5 is not even starting.
    I switched back to Apache because of this. Any fix ?
  7. mistwang

    mistwang LiteSpeed Staff

    can you please PM me a temp root access? I can take a look.
  8. vivek

    vivek Well-Known Member


  9. vivek

    vivek Well-Known Member

    Thank you for the reply.
    So , disabling mod_security from httpd.conf will fix this issue ?
    Actually there is no use of mod_security with litespeed.

    Please let me know when you upload the new fixed package.

  10. vivek

    vivek Well-Known Member

    I just removed the line of mod security from httpd.conf
    Still not loading.
  11. mistwang

    mistwang LiteSpeed Staff

    I will upload the new build and give it a try on port 2080, please keep the ssh access available to me before the issue has been solved.
  12. mistwang

    mistwang LiteSpeed Staff

    LiteSpeed is on now. I set Apache Port Offset to 0.

    A restart takes about 3 seconds, including scanning .ls_rails configuration for each user, if you turn off rails support, it will take less than 1 second.
  13. vivek

    vivek Well-Known Member

    Just checked it.
    Its amazing

    Thank you very much for the fix

Share This Page