Litespeed is not logging

Discussion in 'General' started by TarkanVeKurdu, Oct 17, 2008.

  1. TarkanVeKurdu

    TarkanVeKurdu Member

    Hi ,

    We have a Litespeed box with latest version 3.3.20 on a plesk box . Everything is running fine except the web logs. Litespeed is not logging properly to virtual domain logfiles: /var/www/vhosts/

    I have tried everything but its not working. What could be the problem here ?

    Best regards,
  2. mistwang

    mistwang LiteSpeed Staff

    You need to check the permission of statistics/ and logs/ directory.
    Make sure 'apache' user can read access_log, does not get permission denied.
    Try command

    sudo -u apache more /var/www/vhosts/
  3. TarkanVeKurdu

    TarkanVeKurdu Member

    Well I have tested and apache user can login and reach the access_log files without problems. But lsws is still not logging. Please help.

    Best regards
    Last edited: Oct 20, 2008
  4. mistwang

    mistwang LiteSpeed Staff

    Please PM a temp root login to your server, we can take a look.
  5. TarkanVeKurdu

    TarkanVeKurdu Member

    I PM'ed ! thank you.
  6. mistwang

    mistwang LiteSpeed Staff

    Looks like something wrong with plesk pipe logger used, we will have it addressed soon.
  7. TarkanVeKurdu

    TarkanVeKurdu Member

    Hi !

    I have solved the problem with your help . I enabled the pipe logging on plesk with the help of : . I have disabled the pipe logging then restart the lsws server now its working.

    I only have one problem left and pm'ed that problem . Compression problem. It will be great if you can check that problem.

    Best regards
  8. mistwang

    mistwang LiteSpeed Staff

    When used with a hosting control panel using Apache httpd.conf, LiteSpeed will not compress or rotate the log file, usually the control panel will do that while updating the statistics.

Share This Page