LiteSpeed is not stopping ??

Discussion in 'Install/Configuration' started by vivek, May 29, 2008.

  1. vivek

    vivek Well-Known Member

    Hi there!

    I want to stop litespeed but it is not stopping , still continuing

    I tried these

    root@core2quad [/home/lsws/bin]# ./lswsctrl stop
    [OK] lshttpd: stopped.
    root@core2quad [/home/lsws/bin]#


    root@core2quad [/home/lsws/bin]# service httpd stop
    /etc/init.d/httpd stop: httpd (no pid file) not running
    root@core2quad [/home/lsws/bin]#



    root@core2quad [/home/lsws/bin]# service lsws stop
    root@core2quad [/home/lsws/bin]#





    NONE OF THEM STOPPING LITESPEED


    Plus, using LSWS admin panel, I can not downgrade my version from 3.3.13 to 3.3.12


    Vivek
     
  2. vivek

    vivek Well-Known Member

    Tried
    killall -9 lshttpd

    It stopped but within 2 seconds it restarted.

    Anything wrong from my side ?
     
  3. vivek

    vivek Well-Known Member

    Finally I tried this too for activating apache

    cd /usr/local/apache/bin

    killall -9 lshttpd
    mv httpd httpd1
    killall -9 lshttpd
    mv httpd_ls_bak httpd
    killall -9 lshttpd
    ./httpd restart

    Still loading litespeed :)
     
  4. mistwang

    mistwang LiteSpeed Staff

    kill lswatch.sh
     
  5. vivek

    vivek Well-Known Member

    I dont understand ? I never saw that file before

    Reinstalled lsws now , still have the same problem
     
  6. mistwang

    mistwang LiteSpeed Staff

    Latest official 3.3.13 package should have fixed the cPanel kill lshttpd problem.
     
  7. vivek

    vivek Well-Known Member

    Just installed 3.313 official release and I found that the cpanel is taking only 5-10 seconds for creating an account whereas it was about 20-30 seconds with the wrapper script.

    Also found that the kill problem filxed. everything is now going well

    How do I change back to apache in case if I want to check something in future.


    also I found a new file under the /bin folder lswatch.sh
    What is the use of this ? a restart ??

    is it running as cron ? what is the time interval and also , how can I go back to apache or just stop litespeed if it is running ?
     
  8. mistwang

    mistwang LiteSpeed Staff

    switch to Apache just do

    service lsws stop
    service httpd start

    The /script/restartsrv_httpd should work with either LSWS or Apache, or both.
     
  9. vivek

    vivek Well-Known Member

    root@core2quad [/home/lsws]# service lsws stop
    root@core2quad [/home/lsws]# service httpd start
    /etc/init.d/httpd start: httpd (pid 1898) already running
    root@core2quad [/home/lsws]#


    Still litespeed is loading
     
  10. mistwang

    mistwang LiteSpeed Staff

    lswatch.sh is a watchdog script, it has not be used by default. You start start it manually if you want to keep lshttpd running regardless.
     
  11. vivek

    vivek Well-Known Member

    Sorry,
    service lsws stop

    is stopping litespeed

    but

    service httpd start is not activating Apache

    service httpd restart is activating litespeed again.

    I think /usr/local/apache/bin/httpd is the wrapper script
     
  12. vivek

    vivek Well-Known Member

    oh yes,
    So litespeed must include that too, when user selects OverRide restartsrv_httpd , it should disable the wrapper script.
    it should disable httpd_ls_back to httpd

    Am I right ?
     
  13. vivek

    vivek Well-Known Member

    ok, I renamed httpd_ls_back to httpd, still apache is not loading when "service httpd start"
     

Share This Page