Litespeed, MacOSX, File Descriptors

Discussion in 'Install/Configuration' started by guryla, Jun 29, 2010.

  1. guryla

    guryla Member

    Thanks for the quick response to my last post. I have one more:

    My Litespeed log is showing:

    2010-06-29 11:54:10.764 NOTICE The maximum number of file descriptor limit is set to 18446744073709551615.

    I'm running on Mac OS X 10.5. The file descriptor limits are:

    OS-level: 12288 [command: sysctl kern.maxfiles]
    User-level (soft limit): 256 [command: ulimit -a]
    User-level (hard limit): unlimited [command: ulimit -H -a]

    We are using LS 3.3.15 -- yes, I know we're way behind -- to host a Rails app. We have occasionally seen a problem where a web services client that is embedded in our app will fail trying to resolve the DNS name of the web services server. Hitting that same web services URL from outside of the application (LS/Rails) always works fine. The LS/Rails server does not have a lot of human users, but it does get socked with regular Ajax requests every 20 seconds or so from every user. We've also gotten some recent complaints about occasional dropped connections from users.

    I am thinking we might be bumping into the default soft user-level file descriptor limit, which is only 256 for Macs. (Compared to 1024 for Red Hat.)

    1. Would you expect to see this kind of behavior (failed DNS resolution on web services call) in this situation?
    2. Why is the LS log showing me that huge file descriptor limit? Is that what is meant by "unlimited" or is it just out of range? The docs say that if I start LS as root, it will adjust the limit automatically if it is too low. I typically start it like this:

    sudo /usr/local/lsws/bin/lsctrl start

    Would it be better to use this in order to load root's environment when running it?

    sudo -i /usr/local/lsws/bin/lsctrl start

    Thanks for your help.
  2. guryla

    guryla Member

    Sorry for the red herring. Just realized that 18446744073709551615 is 2**64. So evidently, because I am launching LiteSpeed at root, it is overriding the Mac OS X soft limit on per-process file descriptors. Unfortunately, problem still not solved, but I can't blame it on LS.

Share This Page