litespeed + magento

Discussion in 'Bug Reports' started by kensington, Oct 19, 2010.

  1. kensington

    kensington Member


    I'm using magento om litespeed, and after a switch from apache to litespeed I have a problem.

    Sometimes fail to read the javascript or css on page.
    Sometimes the page is blank page, or loading, loading ....

    Observing the Real-Time status with the litespeed admin Refresh Interval of 5 or more seconds, also sometimes the page goes blank and I think it's the same problem.

    My biggest problem is to record some information in magento. Often stops, sometimes writes and sometimes does not record.
    When does reload the page everything is fine, but just to again.

    Can anyone help me?

    Is there a setting ideal for magento?

    My Server:
    Quad Xeon 8G Ram CentOS LiteSpeed Enterprise 1-CPU
  2. NiteWave

    NiteWave Administrator

    can you compare phpinfo() under apache and litespeed, see any difference ? for example, value of "Configure Command"
  3. kensington

    kensington Member


    Thank you,

    Apache info is:

    './configure' '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--without-mime-magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--disable-json'

    litespeed info:

    './configure' '--prefix=/usr/local/lsws/lsphp5' '--with-pdo_mysql' '--with-zlib' '--with-jpeg-dir=/path/to/libjpeg' '--with-gd' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-magic-quotes' '--enable-mbstring' '--with-iconv' '--with-mcrypt' '--with-curl' '--enable-soap' '--with-litespeed' '--with-mysql' '--with-libdir=lib64'

    I better re-build the same?
  4. NiteWave

    NiteWave Administrator

    right. just remove '--with-apxs2=/usr/sbin/apxs'

    rebuild php using web admin console: Actions --> Compile PHP
  5. kensington

    kensington Member

    I'm sorry,

    '- With-apxs2 = / usr / sbin / apxs' is on the previous server setup, apache.

    The current server with litespeed is below and has no '- with-apxs2 = / usr / sbin / apxs' ...
  6. NiteWave

    NiteWave Administrator

    yes, use same options as apache, just remove '--with-apxs2=/usr/sbin/apxs' or replace it with '--with-litespeed'
  7. kensington

    kensington Member

    Thank you.

    I tried but no improvement ...
    Not my settings?
    Can not find a proper configuration, set up by searching the forum:

    My tuning

    Max Connections:9000
    Max SSL Connections: 100
    Connection Timeout (secs): 1800
    Max Keep-Alive Requests:4500
    Smart Keep-Alive: Yes
    Keep-Alive Timeout (secs): 15
    Send Buffer Size (bytes): 0
    Receive Buffer Size (bytes): 0
    I/O Event Dispatcher: best (All platforms)
    Max Cached Small File Size (bytes):4096
    Total Small File Cache Size (bytes):20M
    Max MMAP File Size (bytes):256K
    Total MMAP Cache Size (bytes): 40M
    Use sendfile(): Yes
    SSL Hardware Accelerator:(built-in) OpenSSL internal engine

    Max Request URL Length (bytes):8192
    Max Request Header Size (bytes): 16380
    Max Request Body Size (bytes): 500M
    Max Dynamic Response Header Size (bytes): 8K
    Max Dynamic Response Body Size (bytes): 500M

    Enable Compression: Yes
    Enable Dynamic Compression: Yes
    Compression Level (Dynamic Content): 1
    Compressible Types: text/*, application/x-javascript, application/javascript, application/xml
    Auto Update Static: Yes
    Compression Level (Static File): 6
    Max Static File Size (bytes): 1M
    Min Static File Size (bytes): 300

    My External App lsphp5

    Max Connections: 80
    Initial Request Timeout (secs): 60
    Retry Timeout (secs): 0
    Persistent Connection: Yes
    Connection Keepalive Timeout: 1000
    Response Buffering: No
    Auto Start: Yes
    Back Log: 100
    Instances: 1
    suEXEC User: not Set
    suEXEC Group: not Set
    Run On Start Up: not Set
    Max Idle Time: not Set
    Priority: 0
    Memory Soft Limit (bytes): 350M
    Memory Hard Limit (bytes): 400M
    Process Soft Limit: 200
    Process Hard Limit: 200

    Is there a problem in that?
    Sorry for the inconvenience, I tried everything possible before writing here, and just step through stressful days.
  8. kensington

    kensington Member

    I am following when opening files on this page, and that the problem is always in the archives. js. css.
    There is always the same file that gives problems.
    Each time one of them is not loading. Or long time to loading.
    The site is quick.
  9. NiteWave

    NiteWave Administrator

    the setting looks normal -- in general, the default setting is ok and no need to change them.

    check error.log, stderr.log, see if any related messages there.
  10. kensington

    kensington Member

    I checked the logs, there is nothing wrong ...
  11. NiteWave

    NiteWave Administrator

    need improve your lsphp5. 2 obvious issues at present: (from phpinfo())
    1>no php.ini
    Loaded Configuration File: (none)

    2>no opcode cache
    although built, but not enable it since 1>
  12. kensington

    kensington Member

    Dear NiteWave,

    Thank you for the excellent support.
    I set up the two items above and everything is ok.:)

    Configured and the APC and was even faster.

    The initial problem, I will be evaluating from today and make the feedback.

    Thank you.;)

Share This Page