Litespeed + webmin

Discussion in 'Install/Configuration' started by NModern, Feb 23, 2010.

  1. NModern

    NModern Member

    CentOS, litespeed, webmin-virtualmin, proftp, mysql

    i have created virtual host in webmin and in litespeed. now i have issue with "Document Root". when i change it to "/home/nadirloc/" everything works fine. But i must place my php files under directory "/home/nadirloc/" and it's not secure. But when i change doc root to "/home/nadirloc/public_html/" it shows error "*path /home/nadirloc/public_html/ is not readable".

    I am new to linux, can anyone help me?
  2. NiteWave

    NiteWave Administrator

    what's the permission of the directory?

    #ls -ald /home/nadirloc
    #ls -ald /home/nadirloc/public_html
  3. NModern

    NModern Member

    drwxr-x--- 8 nobody nadirloc 4096 Feb 23 16:29 /home/nadirloc

    drwxr-x--- 3 nadirloc nadirloc 4096 Feb 23 15:33 /home/nadirloc/public_html
  4. NiteWave

    NiteWave Administrator

    looks your php is running as "nobody". need grant "nobody" read and execute permissions. current permission of /home/nadirloc/public_html is 750.


    chmod 751 /home/nadirloc/public_html

    if still fail, try

    chmod 755 /home/nadirloc/public_html
  5. NModern

    NModern Member

    with 751 it worked fine.

    but now i have another problem. i can read one sties files and folders from another with php.

    how i can prevent this?
  6. NiteWave

    NiteWave Administrator

  7. NModern

    NModern Member

    i have checked retrained yes. but it not helps.
    and i have seleced phpsuexec to "users home directory only". nothing helped.
  8. NiteWave

    NiteWave Administrator

    have you tried set "PHP suEXEC" to "Yes"(instead of "User's Home Directory Only")?
  9. NModern

    NModern Member

    yes i've tried.
  10. mistwang

    mistwang LiteSpeed Staff

    change permission from

Share This Page