lsapi+ruby+rails=some errors in error.log

Discussion in 'Bug Reports' started by kramer, Jan 18, 2010.

  1. kramer

    kramer New Member


    nice work - I mean LSHTTP. Anyway works great with lsapi. Only I'm wondering, why in HTTP server error log I have lines like below:

    2009-11-20 18:42:20.779 [INFO] [] File not found [/opt/

    Need to mention, that Ruby application works ok, and of course I have controler site. Enough to see - works ok , so why errors occurs ? Will look forward some input from you guys.

    Regards from Poland,
  2. mistwang

    mistwang LiteSpeed Staff

    Check your configuration and access log, any where mentions "site" .
  3. kramer

    kramer New Member


    hello mistwang,

    thanks for a quick reply. the problem is not only with site contoller. it is also for all other ruby controllers ie forum, topics, categories as per ruby app.
    controlers created and works fine. server is on debian 5 openvz slice.
    our lshttpd vhost config is like:

    <?xml version="1.0" encoding="UTF-8"?>

    i don't understand why errors occurs, because dispatch.lsapi taking over and
    in public folder no such files like site or topics - they inside ../app/controllers. any help much appreciated.
    before i sent you a extract from error.log - below line from access.log refereing to word site: - - [19/Jan/2010:07:58:58 +0000] "GET /images/border2.png HTTP/1.1" 200 183 "" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/ Safari/532.0" ""

  4. mistwang

    mistwang LiteSpeed Staff

    Are you using a old version of LSWS? should upgrade to the latest.
    And, you are not using the easy rails context configure, but configured the rails dispatcher app manually, that's the reason you get 404 error in log file, but it does not hurt anything, you are using a 404 handler to dispatch request to Rails.
    switch to easy rails context will suppress that message.
  5. kramer

    kramer New Member



    i'm using v4.0.12
    with rails tried to configure in many ways, but only present works fine.
    i understand no harm in 404 in logs, but like to keep my system tidy.
    do you have a pointer to install lsws+ruby+rails in other way to migrate vhost in order to make a better installation ? what you mean: "switch to easy rails context" ??

  6. mistwang

    mistwang LiteSpeed Staff

  7. kramer

    kramer New Member



    i tried this way but with no luck. will try later on again to create another vhost and start from scratch. thanks for all answers. case closed.


Share This Page