lsperld.fpl always times out

Discussion in 'General' started by mabonyi, Feb 11, 2007.

  1. mabonyi

    mabonyi Member

    I use an instance of lsperld to serve old-style awstats on one of my servers and I noticed that on 2.2.6 it works fine, but on 3.0 RC2 it times out. I don't know the reason for the hang, because there are no errors I can see in any of the logs. I use exactly the same settings in both. Here is the lsperld setup:

    Server Level
    Fast CGI app
    Max Connections: 1
    Initial Request Timeout: 120
    Retry: 60
    Persistent: No
    Keepalive: 1000
    Response Buffering: No
    Auto Start: Yes
    Command: /server-root/fcgi-bin/lsperld.fpl
    Back Log: 100
    Instances: 1
    Run on start up: no
    Max idle: 45

    Do I need to change these settings for 3.0, perhaps?
  2. mistwang

    mistwang LiteSpeed Staff

    No, you don't need to change configuration for 3.0RC2. Must be something wrong.
    Did you upgrade from 2.2.6 to 3.0RC2 on the same server? or try 3.0RC2 on another server? Anything in error.log and stderr.log? Can you try a simple "hello world" perl CGI script?
  3. mabonyi

    mabonyi Member

    I upgraded from 2.2.6 to 3.0RC2. A simple hello world script and the both work using CGI daemon, but both hang using lsperld.fpl. I upped the logging to INFO and receive this for the hello world script ( is the same):

    2007-02-11 21:22:29.680 [INFO] [] Connection idle time: 31 while in state: 5 watching for event: 25,close!
    2007-02-11 21:22:29.680 [INFO] [] Content len: 0, Request line:
    GET / HTTP/1.1
    2007-02-11 21:22:29.680 [INFO] [] HttpExtConnector state: 8, request body sent: 0, response body size: 0, response body sent:0, left in buffer: 0, attempts: 0.
    2007-02-11 21:22:29.680 [INFO] [] FcgiConnection watching event: 25, wantWrite: 0, total Pending: 0, buffered: 0, record status: 0, size:0, content len: 8, request processed: 0, total processing time: 31, waiting for response for 31 seconds.
  4. mistwang

    mistwang LiteSpeed Staff

    Can you strace the perl process for lsperd.fpl?
    I tried it on our 3.0 release, works fine.
    You can download 3.0 release by changing the version number in the download link.
  5. mabonyi

    mabonyi Member

    The new version fixed it. The perl scripts are behaving as in 2.2.6 now. Thanks!

Share This Page