LSWS 4.2 support PHP suEXEC daemon mode

Discussion in 'Install/Configuration' started by mistwang, Sep 12, 2012.

  1. mistwang

    mistwang LiteSpeed Staff

  2. eva2000

    eva2000 Well-Known Member

    Hi George, interesting developments indeed :)

    Definitely will have to check out 4.2 when I have the time :D
  3. Elik

    Elik Member

    Bug with litepeed or PHP 5.4.6?

    I have been working on trying to get the PHP 5.4.6 to compile with the new Litespeed SAPI 6.0 and it seems it won't compile at all for it. Were you guys able to have this compiled under PHP 5.4.6? I am falling back down to 5.4.5 for now to see if it compiles with litespeed SAPI update for this.
  4. Elik

    Elik Member is PHP issue

    Okay...apparently, it is PHP issue, since they apparently broke something in the buildconf file for adding the new extensions and such that it broke the litespeed's part to have it added into the system for it.

    So scratch that previous post about it.
  5. Elik

    Elik Member

    Latest update....

    Ok..apparently, the LSPHP SAPI 6.0 is the culprit for having it added into the PHP 5.4.6 to give that errors for not being able to compile. So I guessing the functionality is not updated to work with PHP 5.4.6 yet at this time, correct?
  6. mistwang

    mistwang LiteSpeed Staff

    How do you try to build PHP 5.4.6 with LSAPI 6.0?
    WHM plugin, build matching PHP?
    from LSWS web console?
    Or do it manually from command line?
  7. Elik

    Elik Member

    I do this manually, since I have 3 other PHP builds also running, which is 4.4.9, 5.2.17, 5.3.16 as well and was adding the PHP 5.4.6. Just it seems when I update it with the new LSAPI 6.0 in the php 5.4.6, it fails.
  8. mistwang

    mistwang LiteSpeed Staff

    with PHP 5.3 and above, including PHP 5.4, you do not need to run buildconf, just overwrite sapi/litespeed directory with code from LSAPI 6.0. "--with-litespeed" is supported by default.
  9. Elik

    Elik Member

    Generally, that would be in this case, but I also have added two extensions to the PHP BUILD, which is basically ffmpeg and magick PECL extensions, which is to be compiled statically into the PHP itself.

    So when I also add the LSAPI 6.0 and run the buildconf, that when it barfs for it. I am still trying few ideas to try to get around that issue, but I think I found the answer by your comment, which is to build it first successfully with the extensions added by phpbuild, and then patch the sapi directory with new 6.0 and build it again from there to get it compiled.

    I will update later tomorrow when I get back to it.
  10. mistwang

    mistwang LiteSpeed Staff

    A easy solution is to skip sapi/litespeed/Makefile.frag and config.m4 when overwrite sapi/litespeed directory. buildconf should pass.
  11. Elik

    Elik Member

    That advice worked. That seems to be the point of contention of having it failing to compile when updating it. Thanks.
  12. georgetasioulis

    georgetasioulis Active Member

    Today I upgraded to v4.2 by issuing the following command from command line:
    /usr/local/lsws/admin/misc/ -f -v 4.2
    (PS: Version Manager still shows 4.1.13 as Latest Release...)

    Then I recompiled PHP 5.2.17 via the Admin interface (simply took the configuration options from /usr/local/lsws/fcgi-bin/lsphp-5.2.17 -i), verified that LSAPI 6.0 was downloaded, and tried to enable suEXEC daemon mode by updating lsphp5 external application configuration and changing the Run on Startup option to suEXEC daemon.

    Unfortunately enabling suEXEC daemon mode, gave me 503 errors on all my websites (I'm running cPanel & CloudLinux), so I had to change Run on Startup, back to On.

    Any idea why this could be happening?

    I'll also try it with PHP 5.3.16 in a few minutes and let you know.
    Last edited: Sep 18, 2012
  13. georgetasioulis

    georgetasioulis Active Member

    PHP 5.3.16 also gives me "503 Service Unavailable The server is temporarily busy, try again later!" errors.

    Here's a screenshot from phpinfo:
    Screen Shot 2012-09-18 at 1.13.04 PM.jpg
  14. NiteWave

    NiteWave Administrator

    but this phpinfo() is ok, without 503 error ?
  15. georgetasioulis

    georgetasioulis Active Member

    The phpinfo above is with Run on Startup option set to On.
    If it set it to suEXEC daemon and restart, nothing works, not even the phpinfo page. I get a 503 error instead.

    (the attached phpinfo page is to show you my configuration options and that indeed PHP is compiled with LSAPI 6.0)
  16. mistwang

    mistwang LiteSpeed Staff

    Are you using CageFS or just regular LVE?
    Could be a system resource limit being hit. have you checked stderr.log?
    You can PM me a temp root access if you want, I can take a look.

Share This Page