LSWS chroot broken in 2.1.8?

Discussion in 'Install/Configuration' started by zellster, Dec 23, 2005.

  1. zellster

    zellster Well-Known Member


    I am attempting to install 2.1.8-ent on a dual-proc CentOS 4.2 box. When I select a chroot install, I always get the following error message:

    "Server root is not included in the chroot directory tree"

    Server root in this case is /opt/lsws, and I have tried it with the following created directories:

    (with and without the trailing /opt/lsws, with ownership of root and nobody)

    All give the same error message. Where am I screwing up :)?
  2. zoom

    zoom Well-Known Member

    I'm not sure about the 2.1.8(ent) edition but I did install the 2.1.7(pro) edition into a chroot'd environment successfully. All I did was create a directory

    mkdir /chroot

    Then when prompted by the install script installed LSWS under it.

  3. mistwang

    mistwang LiteSpeed Staff

    If you install lsws to /opt/lsws, then you can only chroot lsws to /opt or /opt/lsws, as the lsws must be installed inside the jail. when you specify the server root path, full path including the jail must be given. :)
  4. zellster

    zellster Well-Known Member

    OK, now it makes sense. Found one other problem while continuing the chroot install:

    Chroot directory without trailing '/': /home/lsws

    Installing, please wait...

    ldd: /home/lsws/fcgi-bin/php: No such file or directory

    Presumably this is from:
    $LSWS_HOME/admin/misc/ $CHROOT_PATH $LSWS_HOME/fcgi-bin/php

    Should php be changed to lsphp?


Share This Page