LSWS dies after every account is created

Discussion in 'Bug Reports' started by ffeingol, Jul 31, 2008.

  1. ffeingol

    ffeingol Well-Known Member


    We have a server with LSWS and cPanel. Every time a new account is created we get this:

    LSWS = 3.3.15
    CentOS 5, 32 bit all patches applied
    cPanel - Release all patches applied

    let me know if I can provide anymore information.

  2. mistwang

    mistwang LiteSpeed Staff

    Which cPanel release are you using? Still run Apache behind LSWS?
    Have you tried "Using Apache httpd wrapper" option?

    cPanel may kill lshttpd with "-9", but it will start /usr/local/apache/bin/httpd again, with the wrapper, LSWS will get started and it should start apache if need.
  3. ffeingol

    ffeingol Well-Known Member

    Yes, we need Apache still there because of SSI. Yes, LSWS gets restarted but Apache does not.

    "override cPanel restart HTTPD script"
    running the latest cPanel Release tree

    Apache is not restarting.
  4. mistwang

    mistwang LiteSpeed Staff

    can you post the content of the wrapper script

    it should be a shell script.

    Also the content of

    it logs the command parameters used when run /usr/local/apache/bin/httpd
  5. ffeingol

    ffeingol Well-Known Member

    I PM'ed you the info.

  6. mistwang

    mistwang LiteSpeed Staff

    I tried in with cPanel 11.23.4-R26138 with Apache 2.2.9, LSWS 3.3.15 (Use Apache binary wrapper). Seems restart Apache from WHM and adding an new account both working fine.
    Our wrapper script matches yours. Do you have "httpd" checked under Service Manager?

Share This Page