Magento 2.2.2 Problem

Discussion in 'LiteMage Cache Extension For Magento' started by Joebordo, Feb 17, 2018.

  1. Joebordo

    Joebordo New Member

    Hi today i purchased a VPS with Litespeed server and standard litemage lisense.
    Provider installed the litespeed server.
    I installed the litemage 2.0.8 extention on my magento 2.2.2 installation. Then i enabled it in htaccess.

    Problem:

    Store>Configuation>system>Litemage
    Only GENERAL settings (enable debug) option is visible, nothing else.

    Also on the cachemanagment page

    I do see
    LiteMage Cache Management (LiteSpeed Web Server)

    but there is nothing under it. it's just the title.

    Is the extension not compatible with magento 2.2.2 ? or am i doing something wrong.

    Also if magento is put into production mode: >the css ect is broken, the page shows broken, but the page does show correct in developer mode.
     
    Last edited by a moderator: Feb 20, 2018
  2. Lauren

    Lauren LiteSpeed Staff Staff Member

    the statistics maybe have some issues for certain scenarios. (will have a fix later) When you need to purge litemage cache, you use the same "Page Cache - FPC" line. There's no separate purge litemage button.
    Does it work? Can you see "litemage,hit" header?
    the css stuff is not related to litemage cache, that's magento's javascript/css cache, you may just need to flush all cache.
     
  3. Joebordo

    Joebordo New Member

    Hi Lauren, I can see the litemage header only when magento is in developer mode. If i put it in production mode, everything breaks on the front end. (this only happens if litemage is chosen as the cache)

    As i said, i can't see the options in litemage (to configure them) only shows debug.

    I found another thread with simialr problem, the user said litemage plugin was not set properly.

    I don't understand what he or she means. So i contacted my vps support to see what's going on.

    Btw there is no virtual host, there is only 1 cpanel account and just has server /cache path for the server.

    Can the virtual host be the problem?
     
  4. Lauren

    Lauren LiteSpeed Staff Staff Member

    If on developer mode, you can see litemage cache hit header, that means cache set up is good.
    If you don't see it, you will need to check your cache root set up first.
     
  5. Joebordo

    Joebordo New Member

    Hi Lauren, the issue with css was misconfgured http/https problem (it was set to https).
    My only problem now:
    It does show the litemage hit and miss in chrome dev.

    But in configuration/litemage = i only see "enable debug"...nothing else..there are no option to choose from
    I can't enable or disbale it,

    Any idea why this happens?
     
  6. Lauren

    Lauren LiteSpeed Staff Staff Member

    that's fine, you enable it from the drop down where you can select built-in cache, varnish or litemage.
    current option is only "enable debug". Magento2 is different, litemage2 is completely new built from litemage1. but should work better than varnish, you can test and compare. If you see a page is litemage miss after you refresh several times, that means you have reached litemage starter limit.
     

Share This Page