Migrating from Apache/cPanel

Discussion in 'Install/Configuration' started by Sindre, Dec 21, 2008.

  1. Sindre

    Sindre Well-Known Member

    Migrating from Apache/cPanel - PHP compile error


    I have installed the trial version of LiteSpeed Web Server following the directions posted here.

    I have installed LSWS parallell to Apache with port offset 2000. Now, when I go to create the PHP5 binary using the "Build Matching PHP Binary" tool in WHM, I get the following error: "Cannot find configuration options!".

    How can I solve this? I also tried to compile PHP through the web admin console -> Actions -> Compile PHP menu using the following config string:

    --enable-bcmath --enable-calendar --enable-exif --enable-fastcgi --enable-ftp --enable-gd-native-ttf --enable-libxml --enable-magic-quotes --enable-mbstring --enable-pdo=shared --enable-soap --enable-sockets --enable-wddx --enable-zip --with-config-file-path=/usr/local/lib --with-config-file-scan-dir=/usr/local/lib/php.ini.d --with-curl=/opt/curlssl/ --with-freetype-dir=/usr --with-gd --with-gettext --with-imap=/opt/php_with_imap_client/ --with-imap-ssl=/usr --with-jpeg-dir=/usr --with-kerberos --with-libdir=lib64 --with-libexpat-dir=/usr --with-libxml-dir=/opt/xml2 --with-libxml-dir=/opt/xml2/ --with-mcrypt=/opt/libmcrypt/ --with-mhash=/opt/mhash/ --with-mm=/opt/mm/ --with-mysql=/usr --with-mysql-sock=/var/lib/mysql/mysql.sock --with-mysqli=/usr/bin/mysql_config --with-openssl=/usr --with-openssl-dir=/usr --with-pdo-mysql=shared --with-pdo-sqlite=shared --with-pic --with-png-dir=/usr --with-pspell --with-sqlite=shared --with-tidy=/opt/tidy/ --with-ttf --with-xmlrpc --with-xpm-dir=/usr --with-xsl=/opt/xslt/ --with-zlib --with-zlib-dir=/usr
    After a LWSW restart, I get the following error when accessing PHP scripts:

    503 Service Unavailable
    The server is temporarily busy, try again later!

    Please advise.

    Thank you,
    Last edited: Dec 22, 2008
  2. jayjaybaby

    jayjaybaby Active Member

    Have you checked stderr.log when receiving the 503 errors? It might shed some information on why thats happening.
  3. Sindre

    Sindre Well-Known Member

    I have no log file named stderr.log. I noticed that I had forgot to remove the '--enable-fastcgi' option in the PHP config string, so I tried to re-compile without that option but to no avail. Same problem.

    Anyway, I though I should be able to use the LiteSpeed WHM plugin to compile the PHP binary based on the current one without having to specify the config options.
  4. jayjaybaby

    jayjaybaby Active Member

    You should have a log file named stderr.log, its created by LSWS. (/pathtolsws/logs/stderr.log)

    Also take a look at this wiki article:

    Main thing to note I believe would to be the trouble shooting section:
  5. Sindre

    Sindre Well-Known Member

    Nevermind. I fixed it. It was a problem with the PHP config string and the prefix path. I had to compile it through the web panel, though. The WHM Plugin was not working.

    Anyway, thanks for your help.
  6. mistwang

    mistwang LiteSpeed Staff

    If the WHM plugin does not work, you can try rebuild Apache with cpeasyapache, our WHM plugin rely on some files created by cpeasyapache. Next time, you can try that.

Share This Page