New install, can't access admin interface

Discussion in 'Install/Configuration' started by djsodom, Sep 10, 2008.

  1. djsodom

    djsodom Active Member

    Okay, this I think is an easy permissions problem, but I can't figure it out.

    When I try to access the admin interface at 7080 I get a 404 Not Found (powered by litespeed).

    I check the lsws/logs/error.log and I see:

    2008-09-10 11:22:02.101 [NOTICE] [AutoUpdate] Checking for new releases...
    2008-09-10 11:22:02.101 [ERROR] execve() failed with errno=13, when try to start Fast CGI application: /root/lsws/bin/updateagent update i386-linux 1 NA!
    2008-09-10 11:22:02.103 [NOTICE] [AutoUpdate] Failed, updateagent exit code: 255
    The user running lsws is nobody. The /lsws/bin/updateagent file was set to root:root so I tried changing it to nobody:nobody but same error.

    Any suggestions?

  2. mistwang

    mistwang LiteSpeed Staff

    What is your OS? 32bit? 64bit?

    The updateagent is not directly related to admin interface.

    Which version of LSWS are you using?
  3. djsodom

    djsodom Active Member

    I'm on a 32bit CentOs linux machine.

    I'm using lsws version 3.3.18.

  4. mistwang

    mistwang LiteSpeed Staff

    Where did you install LSWS to? you may have permission problem if you install to a user's home directory and did not choose to run web server on behalf of that user. Install it to /opt/lsws or /usr/local/lsws if you can.
  5. djsodom

    djsodom Active Member

    That was it. I knew it was something simple.


Share This Page