New installation - 503 Service Unavailable

Discussion in 'Ruby/Rails' started by rhardih, Oct 11, 2008.

  1. rhardih

    rhardih New Member

    Hello all,

    I've just tried my luck with deploying a rails app using Litespeed. Very easy to set up I must say, but I think I'm lacking the final glue to get it working right and I'm kinda stuck.

    I've tested the app on Mongrel using script/server and it works as expected:


    But when I try to load it up on Litespeed, it hangs for a few seconds and then displays this:


    I've gone through a few other posts regarding the 503 error, but none seems to fit my particular situation.

    Any helpful suggestions will be much appreciated!

    Thanks in advance.
    Last edited: Oct 11, 2008
  2. mistwang

    mistwang LiteSpeed Staff

  3. rhardih

    rhardih New Member

    I can't believe I missed that.

    I did some rollbacks on my virtual machine, guess I never got it with the second time around.

    I will now put on my stupid-hat...

    Ok, so far so good.

    The page doesn't hang for a few seconds anymore, but it's still not showing the correct information:


    By the way, the logs page shows these errors. I'm not sure if it is anything related to the problem:


    My stderr.log shows the following:

    2008-10-12 21:23:06.249 
    ActionController::RoutingError (No route matches "/rails/info/properties" with {:method=>:get}):
        /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/routing/recognition_optimisation.rb:67:in `recognize_path'
        /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/routing/route_set.rb:384:in `recognize'
        /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:148:in `handle_request'
        /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:107:in `dispatch'
        /usr/lib/ruby/1.8/thread.rb:135:in `synchronize'
        /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:104:in `dispatch'
        /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:120:in `dispatch_cgi'
        /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:35:in `dispatch'
    So I guess something is awry with the rails routes.

    I hope the solution is not as completely obvious this time :)
  4. mistwang

    mistwang LiteSpeed Staff

    The rails properties page is only available in Development mode.
  5. rhardih

    rhardih New Member

    That makes sense yes, but I've set the server to Development, so if that's the issue it should be working:

  6. mistwang

    mistwang LiteSpeed Staff

    It could be overridden at the rails context level.
  7. rhardih

    rhardih New Member

    Hmm, I'm not sure I completely follow...

    Since it is working without any ado with WEBRick, shouldn't it just load up with LS as well?

    Do I need to tweak any configuration elsewhere?

    I have created a very simple scaffold, but when I try to access that as well, I just get the "We're sorry, but something went wrong." error message. And nothing shows up in the stderr.log this time.

    I'm at a loss again...


    Thanks for your help, but I think my patience has ended. I got up and running with Passenger instead. It just worked somehow.

    Best regards,
    Last edited: Oct 14, 2008

Share This Page