open_basedir not being honored?

Discussion in 'Apache Migration/Compatibility' started by ffeingol, Aug 5, 2007.

  1. ffeingol

    ffeingol Well-Known Member

    We have LSWS running (testing on an alternate port) on a cPanel server. cPanel puts the following lines in httpd.conf:

    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/xxx:/usr/lib/php:/usr/local/lib/php:/tmp"
    After we switch to LSWS I put up a quick phpinfo page for one of the sites and both the local and master values for open_basedir say "not set".
    This is LSWS 3.2.1
  2. ffeingol

    ffeingol Well-Known Member

    I believe I solved my own issue. Buried in the error log was:

    2007-08-04 23:57:23.876 [NOTICE] [config:server:epsr:phpLsapi]'Process Limit' probably is too low, adjust the limit to: 220.

    I bumped the soft/hard limit from 200 to 220 and then things worked much better.

  3. medialayer

    medialayer Active Member

    I've noticed that you've posted in another thread regarding LSAPI settings, etc. Relating back to this, what do you have set for the "Initial Request Timeout"? If it is the default (60) it may be worthwhile to reduce it to 30.

Share This Page