Opencart 3.0.3.1 + Journal 3.0.46 separate Mobile View and Google Search Console

AndreyPopov

Well-Known Member
#1
Opencart 3.0.3.1
Journal 3.0.46
LiteSpeed cache 1.3.1

https://www.priazha-shop.com

in .htaccess uncommented

Code:
### LITESPEED_CACHE_START - Do not remove this line
<IfModule LiteSpeed>
CacheLookup on
## Uncomment the following directives if you has a separate mobile view
RewriteEngine On
RewriteCond %{HTTP_USER_AGENT} "iPhone|iPod|BlackBerry|Palm|Googlebot-Mobile|Mobile|mobile|mobi|Windows Mobile|Safari Mobile|Android|Opera Mini" [NC] RewriteRule .* - [E=Cache-Control:vary=ismobile]
</IfModule>
### LITESPEED_CACHE_END

in Opencart LiteSpeed cache module installed, enabled and separate Mobile View sets.


on desktop show full version view
on mobile show mobile version

but..... Google Search Console says: bad Mobility usability

why!?!?!?!?!



30.04.2020 first attempt use LiteSpeed cache, but foget uncomment Rules in .htaccess
04.05.2020 disable LiteSpeed cache and wait until errors in Google Search Console gone
14.05.2020 again enable LiteSpeed cache, uncomment Rules in .htaccess and again errors in Google Search Console
 

Attachments

Last edited:

serpent_driver

Well-Known Member
#2
You only have to uncomment it if your app has PHP function to detect kind of device. As I know Opencart has no such device detection. Mobile View in OpenCart will be handled by media queries and not by device detection.

Btw. disable Pagespeed. Pagespeed doesn't work correctly and forces too much load. You don't get advantage using Pagespeed.
 

serpent_driver

Well-Known Member
#4
Possible reasons:

- Journal 3 and LiteSpeed cache plugin may have differently working logic to detect devices
- You have Pagespeed active. Pagespeed has no function to detect devices
- You have still inline styles enabled
- You missunderstand what a algorithm for device detection is.
- wrong styled theme -> that is the most likely reason for your problem. https://search.google.com/test/mobile-friendly?id=Q5uc0-eO9SAEo6sqPxlYiA Contact the webdesigner of your theme to correct it. This is not caused by LiteSpeed!!!
 

AndreyPopov

Well-Known Member
#5
until LiteSpeed cache enabled I have not problem with Google Search Console Mobile Usability.

I undestand that "Journal 3 and LiteSpeed cache plugin may have differently working logic to detect devices " - but question how correct this?
 

serpent_driver

Well-Known Member
#6
Either Journal 3 logic or LiteSpeed logic (code) must be changed, but disable Pagespeed, disable inline styles, disable mobile view and try mobile friendly test again. I can't believe that Journal 3 has a device detection. Journal 3 uses media queries for different screen sizes/resolutions, but that isn't a algorithm to detect devices. That is pure Stylesheet.

Check https://www.speedtemplate.de This page has an algorithm to detect devices, so every kind of device gets its own code. This is quite different at your site.

Btw. something is very strange on your server. If I check response header nginx webserver is running instead of LiteSpeed. Have you installed LiteSpeed webserver or was it pre-installed?
 

AndreyPopov

Well-Known Member
#7
I can't believe that Journal 3 has a device detection. Journal 3 uses media queries for different screen sizes/resolutions, but that isn't a algorithm to detect devices. That is pure Stylesheet.
Yes, Journal detect device screen resolution.
but if not enable on LiteSpeed settings separate Mobile View than Mobile View can be seen on Large Desktop version or vise versa Desktop View on mobile device.


but disable Pagespeed, disable inline styles
CSS inline already disabled in Journal settings, cache cleared.

how disable Pagespeed? I find only how disable for Nginx and/or Apache, but only hoster can do these.



Btw. something is very strange on your server. If I check response header nginx webserver is running instead of LiteSpeed. Have you installed LiteSpeed webserver or was it pre-installed?
some strange problem with PHP oh hosting.
15.05.2020 hoster upgrade PHP to version 7.2.31 and at 00:00 my site only show only home page. all other links show 404 error.
yesterday I solve by disable/enable OPcache in Admin Panel. site work whole day.
but today at 00:00 again only home page answer, all other links show 404 error
disable/enable OPcache not help.an that's why return default by hoster Apache.
now step by step return LiteSpeed. right now want enable LiteSpeed cache again.
 
Last edited:

AndreyPopov

Well-Known Member
#11

Attachments

Last edited:
Top