Permissions messed up in 4.0.10

Discussion in 'Install/Configuration' started by Joeperd, Sep 7, 2009.

  1. Joeperd

    Joeperd Member

    Hi, I am having some major problems with my file/user permissions since the last 4.0.10 upgrade.

    This is my tree: (dirs + file owned by user:www-data)
    /home/user/sites/domain.tld/ (=/home/user/sites/$VH_NAME/ = $VH_ROOT)
    /home/user/sites/domain.tld/public_html (here is the document root = $VH_ROOT/public_html/)

    Config files are in: $SERVER_ROOT/conf/$VH_NAME.xml (dir & files owned by lsadm:lsadm)

    lsws runs as www-data:www-data

    When I try to instantiate a VHOST I get this error:
    Please fix error: Virtual Host Root /home/user/sites/domain.tld/ does not exist.

    Could anybody help me to fix this nasty issue?
    (btw where is the documentation for this user permission change?)
  2. auser

    auser Super Moderator

    I have had similar issue and resolved.
    see if following setting works for you:

    chown lsadm:www-data $SERVER_ROOT/conf
    chmod 710 $SERVER_ROOT/conf

    update: looks a bit different with your case. FYI only.
    Last edited: Sep 7, 2009
  3. mistwang

    mistwang LiteSpeed Staff

    adding lsadm to www-data should fix the permission issue.
    Next release we will change admin PHP suEXEC to lsadmin:www-data .
  4. Joeperd

    Joeperd Member

    Well I did that, but without any success. Still get the VHOST error
  5. Joeperd

    Joeperd Member

    Well just solved it.. adding lsadm to www-data did the trick.
    At first I changed the group tot www-data in stead of adding lsadm to it.

Share This Page