PHP compiles fine, but stalls at "Installing PHP"

Discussion in 'PHP' started by andreas, Jun 27, 2009.

  1. andreas

    andreas Well-Known Member


    I am trying to compile PHP 5.2.9 on LSWS 4.0.4 on Opensolaris. The compilation works fine, but then it stalls at the "Installing PHP" stage. I can't find any error messages in the stderr.log or phpbuild/*.log. Any ideas?

  2. andreas

    andreas Well-Known Member

    Installation works when I don't enable the Suhosin extension. With the extension, the problem I described above occurs, and also if I install manually the binary does not work with lsws (php doesn't run although i can start it in the console).
  3. emptymind

    emptymind New Member

    I am also having this error, 4.0.6 Ent, PHP 5.2.10, 9 or 8 (only 3 I tried), Centos 5.3 x64

    Watching the build process on the machine, it finishes the make (successfully), and then just stops, and never continues to make install.

    The script in phpbuild just ends with make and then check for errors.

    running make install by hand in the php-5.2.10 (or whatever version) installs the files into the lsphp5 directory (as specified in --prefix) but only installs the cli sapi. The litespeed sapi version appears to be compiled in the sapi/litespeed directory, running it shows it compiled with litespeed sapi, but copying it into the fcgi-bin directory manually, is just sticking me with 503 errors, and its never starting up.

    the build logs showed that it was detecting a bad autoconf version and suggested downgrading to fix the problem, I was hoping that that would fix it, but after downgrading to 2.13 as per the suggestion the same problem continues to occur.

    I did recall that I upgraded from standard 32bit to enterprise 64bit. Completely removing the lsws directory (after backing it up), and rerunning the to reinstall lsws from scratch appears to work. The phpbuild logs show the install process occurring and all the files are copied correctly. Perhaps something in the upgrade affected the build process? Maybe the switch between 32 and 64bit? Not sure. But thought I would share my experiences with this error.
  4. amaltemara

    amaltemara Active Member

    same problem here, lsws 4.0.10 64-bit, Ubuntu LTS 8.0.4

    I'm having the same problem... Hangs at 'Installing PHP'..

    root:/opt/lsws/phpbuild# tail -f `ls -1 *progress -rt | tail -1`
    Installing PHP

    Tried php 5.2.9, 5.2.10, lsws 4.0.9, 4.0.10....

    btw, I do NOT have suhosin checked, and do NOT any opcode cache checked either..
    Last edited: Aug 8, 2009
  5. mistwang

    mistwang LiteSpeed Staff

    It is know issue with 4.0.10, we will release a new release to address this.
    You can install it manually form shell.

    cd lsws/phpbuild/php-5.2.10
    make install
    cp sapi/litespeed/php ../../fcgi-bin/lsphp-5.2.10

    that's it.

Share This Page