php configure with sapi cannot find --with-litespeed

Discussion in 'Install/Configuration' started by diggs, Dec 23, 2009.

  1. diggs

    diggs Member

    Hello there,

    I've been a litespeed user for a few years now and absolutely love the product. Great work! Recently, in the last few months, I've been having a reoccurring issue with compiling php and was hoping for a point in the right direction to resolve this.

    For the last few years, my server setup has always been the same, compiled manually via ssh, and has always worked flawlessly following the setup guide on the wiki "PHP 4/5 with LSAPI Compile/Install How-To" -> Now when I configure php with the same method, the configure returns unknown option "--with-litespeed". I've tried with the most recently released versions of php 5.3 and 5.2 with the same end result.

    Now here's the really odd part, if I purge the installation folders, re-extract my source files for php and the sapi after the configure fails, and rerun the configure in the EXACT same way, after enough tries I'll get one configure that is able to locate the litespeed option and continue without issue!

    I can't seem to determine what makes this one configure work when all the others fail. My process is not altered at all between tries so it's puzzling why 12 times in a row it cannot find litespeed, and then on try 13 it will find it fine using the same source files and identical setup process.

    All sources I'm using (lsws, lsapi, php) are the most recently available as of today 12/23/09 from the respective websites. I'm running ubuntu karmic server, I have been able to recreate this same issue on ubuntu jaunty and hardy as well. I have not tried any previous os versions than that. I have yet to try another distro and would prefer not to have to as ubuntu is what we use globally here for all our linux servers.

    One thing that I did notice when Jaunty was released was an issue with autoconf installation via aptitude. It installs a newer version that 100% breaks the buildconf of php for me, leaving it not able to be compiled at all. In order to resolve this particular issue in the past, I've simply had to install autoconf2.13 via aptitude instead and then the buildconf of php worked fine after that. Autoconf2.13 appears to still be operating properly without error so I'm inclined to say that this is not the issue, however I cannot be positive of this.

    Any tips or advice on this would be great, I'm somewhat at a loss as to why this is happening.

    Thank you for your time, sorry for the long post.

    ~ diggs
    Last edited: Dec 23, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    For PHP 5.3, LiteSpeed SAPI is included, so, you do not need to run "buildconf" again.
    Sometimes, at the end of configure output, it will say certain configuration is not known, like "--with-litespeed", but actually,it is successful if scroll back to check the SAPI used.

    If buildconf failed for whatever reason, you need to find a way to fix it. You may have issue with certain autoconf release, just try another version.

    You can try our "build PHP" feature in our web console as well, it automates most steps.
  3. diggs

    diggs Member


    This seems to be the case with both 5.3 and 5.2. I guess I never tried to push through after seeing the missing litespeed option in configure (/me smacks forehead for not trying). It is in fact as you stated and if I push through the make install regardless of php reporting the unknown litespeed option, the sapi compiles as it normally should. :)

    Any thoughts on why it does in fact work properly very occasionally and not report the unknown litespeed option?

Share This Page