PHP DNS getmxrr() with lsws 3.3.11

Discussion in 'PHP' started by sofatime, May 12, 2008.

  1. sofatime

    sofatime Well-Known Member


    I have recently upgraded one of our lsws installations from 3.2.4 to 3.3.11. Since then we have a problem with getmxrr(), which is used in a newsletter function of the CMS we use. Apparently sometimes getmxrr() does not give back an answer, possibly due to a timeout.
    At the time of the upgrade of lsws I have also upgraded PHP from 5.2.2 to 5.2.5 and LSAPI from 4.0 to 4.7, but I have also tried lsws 3.3.11 with the old PHP/LSAPI, with the same result. So it must have something to do with lsws. Is there any change in lsws between 3.2.4 and 3.3.11 which could affect this? Any configuration setting which needs to be adjusted? Any other hints?

  2. mistwang

    mistwang LiteSpeed Staff

    It is a PHP problem, if getmxrr() timeout and PHP blocked at that function, it may cause trouble for next request assigned to it. There is not much we can do about.
    Either allocate enough spear PHP processes by setting "PHP_LSAPI_CHILDREN" larger than "Max connections". Or, let LSWS to kill malfunctioning PHP process quickly by "instances" matching "Max connections" and remove "PHP_LSAPI_CHILDREN" env.
  3. sofatime

    sofatime Well-Known Member

    Thank you, I will try that.

Share This Page