Php file uploads result in "connection reset" error

Discussion in 'PHP' started by bazza, Jun 2, 2006.

  1. bazza

    bazza Member


    We are running into a problem when uploading files (specifically images) via php. What happens is that the upload will stop and the user will receive the following message in their browser:

    "Connection Interrupted
    The document contains no data.
    The network link was interrupted while negotiating a connection. Please try again."

    It doesnt happen all the time, and the larger the image to be uploaded, the more prevalent the problem seems to be. 20k images usually upload without a problem, but 500k images may have a problem 75% of the time.

    What is somewhat strange is that on non-live servers (servers with no traffic) the problem does not exist, and the images upload without issue. Sending production traffic to the same server causes the problem to surface.

    I have tried with the following litespeed/php combinantions:

    2.1.16 Enterprise/4.4.2
    2.1.16 Standard/4.4.2
    2.1.15 Standard/4.4.0
    2.1.14 Standard/4.4.0

    The problem persists with all combinations.

    I have tried adjusting the various timeout values, but they dont seem to have any impact. The time elsapsed before the error is retured varies per upload attempt -- sometimes it will be 5 sec, sometimes more than 60 sec, even when the file being uploaded is the same size each attempt.

    Enabling DEBUG logging seems to show the following at or around the time of the connection reset:

    [DEBUG] [idle] [ExtConn] close()

    We are using lsapi in all cases and the image uploads are taking place over SSL. The problem seems to exist when using any browserr and therefore does not appear to be browser-specific.

    Any help tracking down the cause of these connection resets and how to resolve them would be much appreciated.

  2. xing

    xing LiteSpeed Staff


    Can you be more specific on the platform the LiteSpeed/PHP is delpoyed on? Solaris 10? RH Linux?

    If you can, please send the /lswsinstall/conf/httpd_config.xml and the /lswsinstall/vhost/conf/vhost.xml to so we can better replicate your problem.

    One more thing, are you currently using the latest PHP LSAPI currently at version 2.1?
    Last edited: Jun 2, 2006
  3. bazza

    bazza Member


    Sorry about that. All our LiteSpeed deployments Debian Sarge AMD64 and Ubuntu Breezy 64-bit. I will forward the config files to you in a couple minutes.
  4. bazza

    bazza Member


    Sending email to that address fails with this error:
    bad owner for /home/bug/.forward: retry timeout exceeded

    Is there another account where I should send the requested config files?
  5. xing

    xing LiteSpeed Staff

  6. mistwang

    mistwang LiteSpeed Staff

    The problem with bug @ litespeedtech has been fixed. Please send again.

    Can you please try the upload with non-SSL connection, we need to isolate the problem.

    Also, it will help a lot if you can send us the error log with DEBUG logging for analysis.

  7. bazza

    bazza Member


    I resent the files to bug@ and cc'ed xing@

    I will see about trying the uploads over non-SSL and let you know what I discover.

    Regarding the debug log -- in our test environment, I cannot replicate the error, so although I can send the debug log from a production server, it will have lots of un-related info in it. Let me see what I can do.

    Thanks again.
  8. xing

    xing LiteSpeed Staff

    Just an update on this bug. We took this bug report privately and the fix for the problem was committed to our 2.1.17 tree on 6/3. The problem was with file upload operation over a SSL connection. 2.1.17 has not been released to the public.

Share This Page