PHP LSAPI issues on FreeBSD 7.2-R

Discussion in 'PHP' started by Incarnate, Sep 25, 2009.

  1. Incarnate

    Incarnate New Member

    I'm running LS enterprise 4.0.10 in a jail on an x86 FreeBSD 7.2-RELEASE machine. I had PHP working as of earlier 7.0-R, but somewhere along the way it ceased to function. I didn't really notice, as I use PHP as little as possible, but other users eventually brought it to my attention.

    I've been trying to revive it for the last couple of days. I tried compiling it within lsws, which seems to fail from some "make install" file not being found, but does compile php. I tried 5.3.0 and 5.2.10 (I know it has the security problems, but just trying to get a working lsapi binary), without suhosin and with both "default" and minimal configure parameters. All the resulting binaries run fine with -v or -i, can run a hello-world php script locally, and say (litespeed) in the version output.

    I've also tried building it manually, using the base source of 5.2.11 and 5.3.0, and applying the latest LSAPI PHP patches as recommended here, keeping it as simple as possible (no suhosin, etc). These binaries also seem to behave properly, when run from the commandline.

    In fact, I've even tried the old lsphp binary (4.4.7) from 2007.

    In all cases I get a 503 Service Unavailable and lots of this:

    2009-09-24 18:18:05.776 [INFO] [uds://tmp/lsphp5.sock] Connection error: Softwar
    e caused connection abort, adjust maximum connections to 34!
    2009-09-24 18:18:05.776 [INFO] Start listen socket [/tmp/lsphp5.sock].
    2009-09-24 18:18:05.777 [INFO] [lsphp5] pid list size: 1
    2009-09-24 18:18:05.777 [INFO] [lsphp5] add child process pid: 2548
    2009-09-24 18:18:05.778 [INFO] Remove pid: 2548
    2009-09-24 18:18:05.778 [INFO] Pid: 2548 associated with [lsphp5]
    2009-09-24 18:18:05.778 [INFO] ProcInfo Pid: 2548, socket: /tmp/lsphp5.sock
    2009-09-24 18:18:05.779 [INFO] [lsphp5] pid list size: 0, pid stop list size: 0
    2009-09-24 18:18:05.779 [INFO] [uds://tmp/lsphp5.sock] Connection error: Softwar
    e caused connection abort, adjust maximum connections to 33!
    2009-09-24 18:18:05.779 [INFO] Start listen socket [/tmp/lsphp5.sock].
    2009-09-24 18:18:05.780 [INFO] [lsphp5] pid list size: 1
    2009-09-24 18:18:05.780 [INFO] [lsphp5] add child process pid: 2549
    2009-09-24 18:18:05.782 [INFO] Remove pid: 2549
    2009-09-24 18:18:05.782 [INFO] Pid: 2549 associated with [lsphp5]
    2009-09-24 18:18:05.782 [INFO] ProcInfo Pid: 2549, socket: /tmp/lsphp5.sock
    2009-09-24 18:18:05.782 [INFO] [lsphp5] pid list size: 0, pid stop list size: 0

    I have a couple of lsws installs and checked my PHP config against the defaults used elsewhere, and it appears fine (I moved the socket out of /tmp/lshttpd in an attempt to "try anything").

    This really smacks of some really stupid permission issue on my part, and it's entirely possible that I'm being blind and missing something obvious, but I've been over it with a fine-tooth comb and not sure where to look from here.. without digging into some serious debugging, which is more than I want to invest in lsapi.

    I've since compiled 5.2.11+suhosin out of ports as a FastCGI, and have created a localhost interface resulting in working PHP. But, since I completely failed to get the LSAPI interface working, I figured I should post about it (even if it's something stupid on my part), on the offchance that I'm not the only one.
    Last edited: Sep 25, 2009

Share This Page