php segfaults, on 2x litespeed 4.0.20 web servers

Discussion in 'PHP' started by eva2000, Mar 8, 2011.

  1. eva2000

    eva2000 Well-Known Member

    I'm working with a clients' new 2x load balanced web servers

    WHM 11.28.83
    CENTOS 5.5 x86_64 standard
    Litespeed 4.0.20

    I ensured easyapache integration was enabled and ran easyapache to update from PHP 5.2.13 to 5.3.5 unselected CGI in php and tried with eaccelerator enabled and also with it disabled at compile time, but I'm getting lsphp5 segfaults when I enable vBulletin v4.1.2 config.php memcached 1.4.5 server


    Mar  8 01:00:38 host2 kernel: lsphp5[12841]: segfault at 000000001bd6d800 rip 0000000000717f97 rsp 00007fff6568e840 error 4
    Mar  8 01:00:38 host2 kernel: lsphp5[12069]: segfault at 0000000700000020 rip 0000000000718346 rsp 00007fffefa8bc70 error 4
    Mar  8 01:00:38 host2 kernel: lsphp5[12071]: segfault at 0000000406c97528 rip 0000000000717f97 rsp 00007fff354733e0 error 4
    Mar  8 01:00:39 host2 kernel: lsphp5[12070]: segfault at 0000000404033d88 rip 0000000000717f97 rsp 00007fff7500b530 error 4
    web 2

    Mar  8 02:53:14 host3 kernel: lsphp5[22512]: segfault at 0000000000000008 rip 00002b2989989127 rsp 00007fffb3c3fd30 error 4
    Mar  8 02:53:28 host3 kernel: lsphp5[22501]: segfault at 0000000000000000 rip 00002b17e1cc07af rsp 00007fff4150f5d0 error 4
    Mar  8 02:54:02 host3 kernel: lsphp5[23004] general protection rip:7183a8 rsp:7fff9fc562d0 error:0
    Mar  8 02:55:36 host3 kernel: lsphp5[23070]: segfault at 0000000700000020 rip 0000000000718346 rsp 00007fffa482e9e0 error 4
    Mar  8 02:55:52 host3 kernel: lsphp5[23488]: segfault at 0000000000000018 rip 00000000007183a8 rsp 00007fff8ed7b990 error 4
    with easyapache integration enabled, litespeed ends up using /usr/local/lib/php.ini rather than usual lsws path to php.ini but i tried both versions of phpize and php-config and still get segfaults with php 5.3.5


    tar -xvf memcache-3.0.5.tgz
    cd memcache-3.0.5
    ./configure --enable-memcache --with-php-config=/usr/local/bin/php-config
    make && make install
    tar -xvf memcache-3.0.5.tgz
    cd memcache-3.0.5
    ./configure --enable-memcache --with-php-config=/usr/bin/php-config
    make && make install
    I'm confused as just yesterday, I did exact same install for same whm/litespeed and memcached/memcache versions for vBulletin 4.1.2 for another client but only difference is they had PHP 5.3.4 easyapach'd intergrated for litespeed.

    phpinfo compile

    './configure' '--disable-cgi' '--disable-fileinfo' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-wddx' '--enable-zip' '--prefix=/usr/local' '--with-bz2' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-pspell' '--with-sqlite=shared' '--with-tidy=/opt/tidy/' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-xsl=/opt/xslt/' '--with-zlib' '--with-zlib-dir=/usr' '--with-litespeed' 
    So only PHP versions differed. PHP 5.3.4 fine on another vB 4.1.2 server but on these 2x PHP 5.3.5 getting segfaults ?

    But on this install, I can't select PHP 5.3.4 in easyapache only PHP 5.3.3 or 5.3.5 ?
    Last edited: Mar 8, 2011
  2. eva2000

    eva2000 Well-Known Member

    Also is it okay to just recompile php via litespeed admin console so that php versions are mismatched ? i.e. litespeed admin console has PHP 5.3.4 available. while leaving easyapache at PHP 5.3.5 ?
  3. NiteWave

    NiteWave Administrator

    any difference from phpinfo()?

    I think ok to build php from litespeed admin console. It just have an additional lsphp5 binary for try, won't overwrite existing ones(however best to backup them first)
  4. eva2000

    eva2000 Well-Known Member

    both web servers exact same phpinfo but i decided to manually compile via litespeed admin console PHP 5.3.4 with memcached and eaccelerator checkbox checked and these options

    and no more seg faults

    but seems client had edited some vB class_datastore.php init.php files which made memcached report corrupted datastore before, so fixed those files this time, so not sure if it was a combination or not
  5. NiteWave

    NiteWave Administrator

    not sure if it was a combination or not
    if previous lsphp5 binary is saved, can take a quick test by point /usr/local/lsws/fcgi-bin/lsphp5 symbol link to old binary and restart lsws.

Share This Page