Powerful server, Poor performance

Discussion in 'Install/Configuration' started by sahith, Jul 13, 2018.

  1. sahith

    sahith Well-Known Member

    Please check my attachment which is a screenshot i took from my Real-Time Statistics, where you can see req/sec are like 17, but only one connection is active. May i know is there anything wrong? and my server performance is also not much good despite having a powerfull dual xeon processor with 24cores. Capture.JPG
    I need help please.
     
  2. Unique_Eric

    Unique_Eric Administrator Staff Member

    HIHI Sahith,
    Could you share more information like what `does top` shows? Server load?
    Also, what kind of site your are testing? Does cache enabled on it?
    Best,
     
  3. sahith

    sahith Well-Known Member

    Its a wallpaper/images website, where images are being resized always in user screen resolutions. Server load usually stays around 5 out of 24. I can't use cache for this website, as its UI loads dynamically based on user screen resolutions and orientation.
     
  4. Pong

    Pong Well-Known Member Staff Member

    "pool" and "In Use" show connection for that particular moment. It is normal. you set "80" as "PHP Max Conn". WaitQ is 0. It doesn't show any problem. only means low traffic.
    If you like, you can try some benchmark tool like "ab" to push a high traffic to your site, real-time stats should change.
     
  5. sahith

    sahith Well-Known Member

    I also has one problem, frequently my sites are not responding, so i checked litespeed real-time performance. There i found that at that time both pool and inuse are getting filled up. I mean for 80 "maxConn" pool is showing up 80 and Inuse also showing 80. But WaitQ is nill. And all goes normal after 5mins of time.

    Can anyone help please why that is happening. I am not even getting that much peak traffic at those times.

    Please help.
     
  6. Pong

    Pong Well-Known Member Staff Member

    That's normal. You may just have 80 connection at that particular time. When WaitQ is 0, then everything is fine. If WaitQ constantly > 0, you should adjust MaxConn to higher number to accommodate such requests/connection level.
    Better try to utilize cache since it is the fundamental performance booster. Not sure why you need such UI design (loads dynamically based on user screen resolutions and orientation) , the responsive theme seems doing much better job and super faster when cache enabled.
     
  7. sahith

    sahith Well-Known Member

  8. Pong

    Pong Well-Known Member Staff Member

    sure, we will continue the discussion on the new thread then.
     

Share This Page