Problem with KML files

Discussion in 'Bug Reports' started by tech-nova, Nov 18, 2011.

  1. tech-nova

    tech-nova Member


    I've got a problem with some KML files that become invalid when I use Litespeed (and are valid when I use Apache).

    My goal is to insert them in Google map.

    For example, this file :

    -> I first copy it (with wget) on an Apache server :
    Then I can paste this url into Google map -- cf. the result :

    -> If I copy this file on a LiteSpeed server :
    I can't use it in Google Map because the KML file appears to be invalid -- cf. the result :

    The only difference I see in the http header of the result is the Etag value, and the order of the other parameters. Something strange too is that GMaps waits a long time to return the error.

    Do you see where can be the problem ?

    Thanks for any tip,

    My Version is lsws-4.1.7 - ent - x86_64
  2. mistwang

    mistwang LiteSpeed Staff

    You can try turning off keepalive of LSWS, google may have difficulty with reading keepalive response from LSWS. I guess.
  3. tech-nova

    tech-nova Member

    It doesn't work
    - Configuration > Tuning : Smart Keep-Alive : No + Keep-Alive Timeout (secs) : 0

    As I'm using cPanel, I've also defined the KeepAliveTimeout : 0 into the Apache conf. - But I think that it doesn't interfere.

    As you suggest, I'll also ask for support in the forums for Google Map API.

    But am I the only one where a KML readed from LSWS isn't considered a valid by this api ?
  4. tech-nova

    tech-nova Member

    Problem with KML files [SOLVED]


    it works now, I don't know why.
    Maybe a conflict between the KeepAliveTimeOut for apache.conf and the configuration of Litespeed used with cPanel.

    Thanks for the tip,


Share This Page