Problem with SVG

Discussion in 'General' started by oreon, Sep 12, 2018.

  1. oreon

    oreon New Member

    Hi guys,

    I have gzip compression working for just about all elements on my site but for some reason SVG files are not getting compressed.

    The htaccess file contains the following:
    Code:
    <IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/x-httpd-php
    AddOutputFilterByType DEFLATE application/x-httpd-fastphp
    AddOutputFilterByType DEFLATE image/svg+xml
    AddOutputFilterByType DEFLATE application/x-font-ttf
    AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    AddOutputFilterByType DEFLATE font/opentype font/ttf font/eot font/otf
    </IfModule>
    The headers of the file match and everything else is getting compressed. Any suggestions?

    oreon
     
    Last edited by a moderator: Sep 12, 2018
  2. Pong

    Pong Well-Known Member Staff Member

    seems svg, svgz image/svg+xml in LSWS default MIME type and it should work.
    Can you provide a URL of svg file to check and ensure "image/svg+xml"?
     
    Last edited by a moderator: Sep 13, 2018

Share This Page