quic crashing

Discussion in 'General' started by m00ster, Jul 16, 2017.

  1. m00ster

    m00ster New Member

    Hello,

    I have been experiencing QUIC related crashes for LSWS:

    ====
    2017-07-16 06:19:42.801 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets of process with pid=25487 !
    2017-07-16 06:19:42.802 [NOTICE] [AutoRestarter] child process with pid=25487 received signal=11, a core file has been created!
    2017-07-16 06:19:43.113 [NOTICE] [AutoRestarter] new child process with pid=25520 is forked!
    2017-07-16 06:19:45.422 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets of process with pid=25520 !
    2017-07-16 06:19:45.422 [NOTICE] [AutoRestarter] child process with pid=25520 received signal=11, a core file has been created!
    2017-07-16 06:19:45.736 [NOTICE] [AutoRestarter] new child process with pid=25587 is forked!
    2017-07-16 06:19:45.736 [NOTICE] [Child: 25587] Setup swapping space...
    2017-07-16 06:19:45.736 [NOTICE] [child: 25587] Successfully change current user to nobody
    2017-07-16 06:19:45.736 [NOTICE] [Child: 25587] Core dump is enabled.
    2017-07-16 06:19:45.736 [NOTICE] [Child: 25587] LiteSpeed/5.2 Enterprise starts successfully!
    2017-07-16 06:19:45.739 [INFO] [PID 25587] [QuicShm::cleanupOldShmData]: cleaning up dead process SHM (pid: 25520)
    ====

    The configuration is pretty generic - standard cPanel/CloudLinux install.

    I would be more than happy toi let you access the server to check out the core dumps if needed.

    Thanks!
     
  2. mistwang

    mistwang LiteSpeed Staff

    Please update the latest build of 5.2, currently build 4, with command
    /usr/local/lsws/admin/misc/lsup.sh -f -v 5.2
    Please install gdb: yum install gdb
    If the crash continues, we may need to login to your server to figure out the root cause.
     
  3. m00ster

    m00ster New Member

    Hello,

    Thanks for the reply.

    This is happening with build 4 and I have gdb installed. If you give me your ssh public key I can add it for you.

    Thanks!
     
  4. Pong

    Pong Well-Known Member Staff Member

    You can log a ticket ( or send email to bug@litespeedtech.com) with us to by providing your server details there. We will give your key there and will take a further look.
     
  5. Hedloff

    Hedloff Well-Known Member

    Did you get it to work?
    I have issues with 5.2 build 8 and cPanel version 64 (build 36). Quic is not working anymore.
    I also tried to disable CSF completely, but still no QUIC!

    Tested with Google Chrome 59.0.3071.115
     
  6. NiteWave

    NiteWave Administrator

    please check if this is also your case:
     
  7. Hedloff

    Hedloff Well-Known Member

    Strange why they do that. It was default, changed it to On and now it's working :) Thanks ;)
     
    NiteWave likes this.

Share This Page