[Resolved] Apache logs not being written

Discussion in 'Apache Migration/Compatibility' started by innovot, Jul 29, 2015.

Thread Status:
Not open for further replies.
  1. innovot

    innovot Well-Known Member

    Hello:

    we are using the Apache compatibility mode no access log files are being written ? In our vhost configuration we have:

    ErrorLog logs/
    Code:
    www.somedomain.co.uk.error.log
    CustomLog logs/
    Code:
    www.somedomain.co.uk.access.log
    combined env=!dontlog

    is it due to the environment variable we set in a separate configuration which has:

    SetEnvIf Remote_Addr "127\.0\.0\.1" dontlog

    Thanks.
     
  2. mistwang

    mistwang LiteSpeed Staff

    It turns off access for requests from 127.0.0.1, but other requests will be logged.
     
  3. innovot

    innovot Well-Known Member

    That is the problem mistwang, other requests are not being logged.
     
  4. innovot

    innovot Well-Known Member

    Still cannot get any access requests logged :(
     
  5. mistwang

    mistwang LiteSpeed Staff

    The way LiteSpeed works now is that it ignore "env=!dontlog" part in customlog,
    whenever dontlog env is set, acccess logging is turned off for that request.
    I tested similar configuration, it works fine.

    Please check the permission along the path to the log file, make sure the file can be opened by the user that LSWS worker process running as.
    Code:
    sudo -u nobody touch /path/to/access_log_file
    if you comment out "SetEnvIf ...", will access logging work?
     
    Last edited by a moderator: Sep 12, 2017
  6. innovot

    innovot Well-Known Member

    Resolved as it was the UID the worked process was running under. Thank you.
     
Thread Status:
Not open for further replies.

Share This Page