[Resolved] DirectAdmin: problem with log files

Discussion in 'Apache Migration/Compatibility' started by svyturio_alus, Aug 19, 2010.

  1. svyturio_alus

    svyturio_alus Member


    I've set up my DirectAdmin with Litespeed (Trial version) by following the user guide at:

    The problem is that none of the log files get updated. From the moment that I've shut down the Apache server, there are no new requests logged in the log files.

    However, in the Error Log I could see warnings appearing:
    2010-08-19 08:15:23.605 [WARN] /usr/local/directadmin/data/users/username/httpd.conf:41: Directive 'suPHP_UserGroup' is not allowed in current context.

    These are made with every Litespeed server restart on every virtualhost. I have also found a forum thread about the suPHP_UserGroup warning, saying that the warnings are safe to ignore (litespeedtech.com/support/forum/showthread.php?t=2347).

    What I've tried without any success:
    chown /var/log/httpd/domains directory to apache:nobody
    chown /var/log/httpd/domains directory to apache:apache
    chmod 0777 /var/log/httpd/domains
    chmod 0777 /var/log/httpd/domains/*
    ..chown individual log files of one domain to apache:apache.

    Thank you for any help
    Last edited by a moderator: Aug 20, 2010
  2. mistwang

    mistwang LiteSpeed Staff

    If you direct admin uses piped logger, you can download the 4.0.17 build by changing the version number in the link.
  3. svyturio_alus

    svyturio_alus Member

    Now I've tried 4.0.17 build as you suggested however nothing has changed and the logs are still not functioning.

    At first, I have tried to upgrade to 4.0.17 (didn't fix the problem) and then I've done a reinstall (using the installer) which didn't fix the problem either.

    Should I try getting rid of Litespeed completely and installing it again?

    Here's an example from user's httpd.conf (had to replace www with xxx because of the forum):
    <VirtualHost >
            ServerName xxx.some.domain.com
            ServerAlias xxx.some.domain.com some.domain.com
            ServerAdmin webmaster@some.domain.com
            DocumentRoot /home/someuser/domains/some.domain.com/public_html
            UseCanonicalName OFF
            SuexecUserGroup auto auto
            CustomLog /var/log/httpd/domains/some.domain.com.bytes bytes
            CustomLog /var/log/httpd/domains/some.domain.com.log combined
            ErrorLog /var/log/httpd/domains/some.domain.com.error.log
            <Directory /home/someuser/domains/some.domain.com/public_html>
                    Options +Includes -Indexes
    Domains directory:
    drwxrwxrwx 2 apache nobody 36864 Aug 19 21:07 domains

    Newly created user's logs:
    -rw-r--r-- 1 apache testuser 0 Aug 19 20:55 test.domain.com.bytes
    -rw-r--r-- 1 apache testuser 906 Aug 19 21:48 test.domain.com.error.log
    -rw-r--r-- 1 apache testuser 0 Aug 19 20:55 test.domain.com.log

    User's logs (777 permissions, even though it should not be required):
    -rwxrwxrwx 1 apache otheruser 148577 Aug 19 07:01 domain.com.bytes
    -rwxrwxrwx 1 apache otheruser 128376 Aug 19 21:48 domain.com.error.log
    -rwxrwxrwx 1 apache otheruser 6514879 Aug 19 07:01 domain.com.log

    Log files are not empty because I've been using Apache on this Vhost before the LSWS install.

    Last edited: Aug 23, 2010
  4. svyturio_alus

    svyturio_alus Member

    Would like to give an update that I've tried uninstalling litespeed using the steps from the installation guide (+ removal of the lsws dir completely). Now using newly installed 4.0.17 and still experiencing the problem. :(
  5. mistwang

    mistwang LiteSpeed Staff

    Please PM a temp root login, I can take a look.
  6. mistwang

    mistwang LiteSpeed Staff

    It is a permission problem with /var/log/httpd
    Piped logger is not used.
    chown apache /var/log/httpd
    fixed it .
  7. svyturio_alus

    svyturio_alus Member

    That simple, I am thankful. Ready to take the next steps of setup before purchasing my first license ;)

Share This Page