[Resolved] FrontPage Instructions for LiteSpeed + cPanel

Discussion in 'General' started by tina, Apr 21, 2010.

  1. tina

    tina Well-Known Member

    We tried running the following which you recommended:

    But users are still unable to publish using FrontPage.

    Is this still the correct command to run on the latest stable cPanel 11.25.0-S44718 ?
    Last edited by a moderator: Apr 22, 2010
  2. tina

    tina Well-Known Member

    We found that running the above command followed by /scripts/fixfrontpageperm does not actually chmod or chown the service.pwd files.

    When we manually changed service.pwd with the correct ownership and permissions, it works for the user, but the ownership and permissions keep getting changed back (not during cPanel updates).

    We are guessing that they are somehow automatically changed back every time the user publishes using FrontPage.

    Surely there are many other LiteSpeed + cPanel users running into this problem with FrontPage?
  3. Tony

    Tony Well-Known Member

    It has been fine for us since 4.0.5 when they did this:

    Added support for mod_auth_passthrough to seamlessly integrate with cPanel FrontPage extension.

    We just enable frontpage in the lsws panel and it all works for the users.
  4. tina

    tina Well-Known Member

    Thanks Tony, does that mean that your service.pwd files are still at cPanel's default ownership user:user and permissions 0600, and it still works perfectly?
  5. Tony

    Tony Well-Known Member

    Yep that's right. Previously it involved those commands and some other things to get it to work for a user which broke after every cPanel update. Since that change everything worked fine with the default permissions.
  6. tina

    tina Well-Known Member

    Understood; thanks again for your very kind responses.

Share This Page