[Resolved] Index not being processed

Discussion in 'Apache Migration/Compatibility' started by innovot, Jul 27, 2015.

Thread Status:
Not open for further replies.
  1. innovot

    innovot Well-Known Member

    Hello:

    am testing a wordpress site and the friendly names work fine but when going to the root directory index.php is not being processed. Am using Apache configuration files and not native LSWS.

    Thoughts please ?
     
  2. mistwang

    mistwang LiteSpeed Staff

    Are you using a control panel? cPanel? plesk? Directadmin? customized?
    I assume the index.php works for Apache, right? Any customization to .htaccess?
     
  3. innovot

    innovot Well-Known Member

    No control panel and Apache works fine with

    Code:
    <VirtualHost *:80>
        ServerAdmin noc@domain.co.uk
    
        ServerName  www.domain.co.uk
        ServerAlias domain.co.uk
    
        RewriteCond %{HTTP_HOST} !=www.domain.co.uk
        RewriteRule ^ http://www.domain.co.uk%{REQUEST_URI} [R=301,L]
    
        RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
        RewriteRule .* - [F]
    
        DocumentRoot /www/www.domain.co.uk/wordpress
        ErrorLog logs/www.domain.co.uk.error.log
        CustomLog logs/www.domain.co.uk.access.log combined env=!dontlog
    
        <Directory /www/www.domain.co.uk/wordpress>
           Options FollowSymLinks
           AllowOverride all
           Require all granted
        </Directory>
    </VirtualHost>
     
    Last edited by a moderator: Apr 21, 2017
  4. mistwang

    mistwang LiteSpeed Staff

    You need to let LiteSpeed read httpd.conf instead of a virtual host configuration file or a configuration file included by httpd.conf. The "DirectoryIndex .." configuration is not present in the vhost configuration, it must be inherit from Global/Default vhost configuration.
     
  5. innovot

    innovot Well-Known Member

    Thank you very much that worked great. Regards.
     
Thread Status:
Not open for further replies.

Share This Page