[Resolved] module is incompatible with LSWS and will cause file permission problems if not disabled.

Discussion in 'General' started by georgetasioulis, Aug 13, 2017.

  1. georgetasioulis

    georgetasioulis Active Member

    Hello,
    After upgrading a cPanel server to LSWS 5.2, I see this error in the LiteSpeed cPanel plugin dashboard:
    Code:
    The module is incompatible with LSWS and will cause file permission problems if not disabled. Please go to "EasyApache 4" under Software and disable this module.
    
    (screenshot: https://cl.ly/lz04)

    However, it's not saying *which* module is incompatible. Any ideas?

    Thanks in advance,
    -G.
     
  2. Usman Nasir

    Usman Nasir Member Staff Member

    Do you have mod_ruid2 enabled?
     
  3. georgetasioulis

    georgetasioulis Active Member

    I just checked an no, I don't have it enabled (or even installed).

    PS: This is a server that's working perfectly fine for months (even now with this error). It just started showing up after I upgraded to v5.2
     
  4. Usman Nasir

    Usman Nasir Member Staff Member

    Can you please create ticket with your login details?
     
  5. georgetasioulis

    georgetasioulis Active Member

    This has been resolved by LiteSpeed support. Thanks a lot!
     
  6. Michael A

    Michael A Administrator Staff Member

    Hello everyone,

    For others who might be encountering this issue, it turns out that some of our planned WHM plugin v2.2.2 changes slipped out a little earlier than intended.

    We are working on rebuilding our current package to fix this. I will post again when that is ready.

    Regards,
    -Michael
     
  7. Michael A

    Michael A Administrator Staff Member

    For the time being, this message can either be (safely) ignored, or removed by force updating to the debug build of 5.2 with command
    Code:
    lsws/admin/misc/lsup.sh -d -f -v 5.2
     
  8. ffeingol

    ffeingol Well-Known Member

    We're still seeing this message on 5.2.2 build 4. We're ignoring it, but is there a solution to make it go away?
     
  9. Michael A

    Michael A Administrator Staff Member

    Hello ffeingol,

    The message should be working correctly in that version, have you checked to see that the mentioned module is disabled in EasyApache?

    Regards,
    -Michael
     
  10. bennieblanco

    bennieblanco Active Member

    This is till ongoing , checked and ruid2 is disabled
    http://prntscr.com/k1t0hi

    or is it?
     
    Last edited by a moderator: Jul 3, 2018
  11. Pong

    Pong Well-Known Member Staff Member

    Ensure that ITK, mod_ruid2, and suEXEC are not present in EA3/EA4's implementation of Apache. If it is, you can either disable FileProtect (/scripts/disablefileprotect) or you can remove the offending modules from Apache and re-run /scripts/enablefileprotect

    Our latest WHM plugin should include disabling fileprotect for you already.
     

Share This Page