[Resolved] module is incompatible with LSWS and will cause file permission problems if not disabled.

#1
Hello,
After upgrading a cPanel server to LSWS 5.2, I see this error in the LiteSpeed cPanel plugin dashboard:
Code:
The module is incompatible with LSWS and will cause file permission problems if not disabled. Please go to "EasyApache 4" under Software and disable this module.
(screenshot: https://cl.ly/lz04)

However, it's not saying *which* module is incompatible. Any ideas?

Thanks in advance,
-G.
 
#3
I just checked an no, I don't have it enabled (or even installed).

PS: This is a server that's working perfectly fine for months (even now with this error). It just started showing up after I upgraded to v5.2
 

Michael A

Administrator
Staff member
#6
Hello everyone,

For others who might be encountering this issue, it turns out that some of our planned WHM plugin v2.2.2 changes slipped out a little earlier than intended.

We are working on rebuilding our current package to fix this. I will post again when that is ready.

Regards,
-Michael
 

Michael A

Administrator
Staff member
#7
For the time being, this message can either be (safely) ignored, or removed by force updating to the debug build of 5.2 with command
Code:
lsws/admin/misc/lsup.sh -d -f -v 5.2
 

Michael A

Administrator
Staff member
#9
Hello ffeingol,

The message should be working correctly in that version, have you checked to see that the mentioned module is disabled in EasyApache?

Regards,
-Michael
 

Pong

Well-Known Member
Staff member
#11
Ensure that ITK, mod_ruid2, and suEXEC are not present in EA3/EA4's implementation of Apache. If it is, you can either disable FileProtect (/scripts/disablefileprotect) or you can remove the offending modules from Apache and re-run /scripts/enablefileprotect

Our latest WHM plugin should include disabling fileprotect for you already.
 
Top