[RESOLVED] PHP Installation Errors

Discussion in 'Install/Configuration' started by Cool-R, Oct 24, 2010.

  1. Cool-R

    Cool-R New Member


    I've been trying to update PHP using the Actions -> PHP. (admin panel)

    I have tried it on CENTOS an Debian 64 bit, Got same errors.

    I'm including Logs for easier understanding.

    **MAIN_STATUS** retrieved from /usr/local/lsws/phpbuild/buildphp_1287909439.5.progress
    Preparing all source code for building PHP 5.3.3 with LSAPI
    Retrieving PHP source archive from LINK
    Extracting PHP source archive: tar -zxf php-5.3.3.tar.gz
    Retrieving Suhosin patch from LINK
    Patching source with Suhosin patch
    **ERROR** Could not patch source with Suhosin patch
    I'm not really good at Linux but If someone could tell me how this can be fixed, I'd appreciate it. Is it a bug with Litespeed? Or I need to edit something to get it done automatically.
    Last edited by a moderator: Oct 26, 2010
  2. NiteWave

    NiteWave Administrator

    install a command "patch"

    apt-get install patch.x86_64

    may resolve the issue. "patch.x86_64" may not be exact debian package name. "aptitude search patch" to get the right name.
    Last edited: Oct 24, 2010
  3. Cool-R

    Cool-R New Member


    Thanks for your kind help. Yep, I've done this.

    Ran it, It went fine.

    Went to the next page. Now It's asking me to run this on Shell

    I ran it. Everything was fine untill at the end, I got this error.

    I'll exlain my fixes(if found any) in detail so that others can overcome them :)
  4. Pipert

    Pipert New Member

    You need gcc installed.


    apt-get install gcc
  5. Cool-R

    Cool-R New Member

    Thanks for the help Pipert. I was about to do that (Googled it :) )

    I did that and re-ran it. I got this error.

    Tried apt-get install xml2 and
    apt-get install libxml2

    No luck (Although xml2 got installed)

    EDIT: Worked!

    Solution:apt-get install libxml2-dev

    Thank you Google :D

    But, I got an error again!

    Last edited: Oct 24, 2010
  6. Cool-R

    Cool-R New Member

    Can anyone tell me how to fix it.

    I just need know that I need to install zlib I think.(If I'm not wrong)
  7. mistwang

    mistwang LiteSpeed Staff

    install libz-dev
  8. Cool-R

    Cool-R New Member

    Thanks for your help, I was hassling with the tutorial on the other website.

    I've got this error again!

    I must say you have good support, It's really good to see developers really helping out :)
  9. Cool-R

    Cool-R New Member

    Soulution found:

    But now,
    What are all the stuff that I have to take care?
  10. Cool-R

    Cool-R New Member


    I have tried to install this.

    EDIT: Got this error

  11. Cool-R

    Cool-R New Member

    Is there anyway I could run it without exhausting my memory? Atleast for now?
  12. NiteWave

    NiteWave Administrator

  13. Cool-R

    Cool-R New Member


    Thanks for the reply.

    How Do I possibly disable fileinfo?

    Any help would be appreciated.
  14. NiteWave

    NiteWave Administrator

    add "--disable-fileinfo" as a php build parameter

    i.e., when you see
    "--with-mysqli --with-zlib ..."
    add the option to become
    "--disable-fileinfo --with-mysqli --with-zlib"
  15. Cool-R

    Cool-R New Member


    Thanks for your help. That solved the thing.

    Everything went fine untill this,
    EDIT: I'm trying this

    Last edited: Oct 25, 2010
  16. Cool-R

    Cool-R New Member

    install autoconf

    Worked great!


    I was just wondering if Litespeed can check these dependencies and install them & run this? Could be handy.

    Pretty much thanks to developers.

Share This Page