[RESOLVED] SUExec Problem

Discussion in 'General' started by robfrew, Mar 20, 2010.

  1. robfrew

    robfrew Well-Known Member

    Hello everyone,

    We just upgraded to a new server and transferred our litespeed configuration over to it. Everything seems to be running fine except for the SuExec.

    I checked the VH config and 'ExtApp Set UID Mode' is set to 'DocRoot UID.' The permissions for the VH doc root are www:www. LSWS uses nobody:nobody.

    However, when we do a test upload using php, it saves the file as nobody:nobody instead of www:www. This tells me that LSWS is not applying 'Set UID Mode' correctly.

    I had to change the permissions to 0777 for all of our upload directories just to allow php to upload a file to them because of it. I don't want that.

    We've restarted the server several times and even stopped and started it to make sure.

    This all worked fine before the transfer. Any ideas? :confused:
    Last edited by a moderator: Mar 20, 2010
  2. robfrew

    robfrew Well-Known Member

    Nevermind. I found the problem.

    Apparently, I had two VH configs, one for port 80 and one for port 443 (ssl). They both used the same php socket but the SetUID config for 443 was set to Server instead of Doc Root which overrode the setting for port 80.

    I just changed it to Doc Root and now it works fine again.
  3. NiteWave

    NiteWave Administrator

    Good sharing

Share This Page