Running short of concurrent connections

Discussion in 'General' started by sth, Aug 29, 2007.

  1. sth

    sth Member

    I have a litespeed server 3.2.1.

    On Log viewer I have many of this WARN messages:

    2007-08-29 17:23:59.575 WARN [] Running short of concurrent connections.

  2. Dani

    Dani Well-Known Member

    as I said in my thread that I created before you, the reason is simply because you have to many visitors and the free version can't handle it...

    free vs enterprise.
    Max Concurrent Connections 150 Unlimited (500 for VPS license)
  3. Dani

    Dani Well-Known Member

    to LS support:

    I'm getting this with enterprise edition. Should I keep increasing (Max Connections) ? Currently I use around 2k, looking at cacti the "Plain connections" under "used" is around 100 does these settings have anything to do to eachother?

    Also I'm using smart keepalive since we have alot of images, with a 3 second timeout on the leep alive.

    Also when we would purchase a ent. licence would we get some optimize help from your team for the installation or would I need to write to the forum for feedback since there is not good documentation over all settings yet?
  4. mistwang

    mistwang LiteSpeed Staff

    Yeah, those are related. Max Connections around 2K is more than enough for your current usage.

    If every page contains new images, you may turn off smart keep-alive. But it is not that critical.
  5. jp_n9

    jp_n9 Active Member

    I just started getting these error messages too!

    I have only 4 low traffic sites running on LiteSpeed. Could I really be using up 150 concurrent connections?
  6. sofatime

    sofatime Well-Known Member

    Me too. :)

    This is lsws 3.2.2 std. Solaris 10 x86 in a Solaris Zone.

    I recently upgraded from 3.2 to 3.2.2, with 3.2 it did not happen. There is not much traffic on the server. It seems that some connections are not being closed properly. When I restart the server the problem is gone but after some time it pops up again. Some strange facts:

    - on the screen "Real-Time Stats" at "_Server/Requests in Processing" I see a high/growing number
    - at the same time "Requests in Processing" is nearly 0 for all virtual servers. How can that be? I always thougt that _Server is the total of all virtual servers. Is that not true?

    The CMS running on the server sometimes does HEAD requests to the server itself (I don't know why, seems a bit stupid, but the CMS is not maintained by me). Could it be that these local HEAD requests are not closed properly? I can see them using "netstat -a".

    Anybody got an idea? Restarting lsws every few hours is not a good solution, even upgrading to Enterprise would only lead to fewer restarts.

  7. mistwang

    mistwang LiteSpeed Staff

    Please check number of concurrent connections used from the real-time report in web admin console. Also check it with command
    netstat -an | grep 80 | grep ESTA | wc
  8. sofatime

    sofatime Well-Known Member

    netstat gives me only 4 established connections to port 80 right now. At the same time the real-time report shows me for _Server 49 and zero for the virtual hosts (Requests in Processing). _Server was at around 50 for the last few hours.
    In error.log I have "Reached per client connection hard limit: 50" every second or so.

  9. mistwang

    mistwang LiteSpeed Staff

    I see, we will have it addressed in next release.
  10. sofatime

    sofatime Well-Known Member

    Ok thanks.
    In the mean time something came to my mind: I have two other lsws installations (one std, one ent). The problem did not happen on those two. They are all configured about the same, except one setting: I/O Event Dispatcher is set to "best" for the servers which do not show the problem and it was set to "devpoll" on the server with the problem. Is there any connection between the dispatcher and this problem? I have now set the dispatcher to "best" on the server with the problem too and will see if this changes anything.
  11. sofatime

    sofatime Well-Known Member

    Switching Dispatcher didn't change anything, _Server is at 50 again.
  12. sofatime

    sofatime Well-Known Member

    This problem gives us some headaches and I now wonder if I should downgrade. I know that you can switch versions easily in the webadmin, but the last version we used was 3.1.1. Can I downgrade by using the installer of 3.2.1 or is that not recommended? Or is 3.2.3 out soon?
    Thanks for a recommendation.
  13. mistwang

    mistwang LiteSpeed Staff

    Yes, you can downgrade. But it may exist in 3.2.1 as well.
  14. sofatime

    sofatime Well-Known Member

    Ok, I downgraded to 3.1.1. Version 3.2.1 and 3.2 have the bug too.
  15. semprot

    semprot Well-Known Member

    I came from google and found this thread.
    On my peak hours i get same warning too on my lsws.
    Now i've changed it from 2000 >> 4000.
    I will wait the effect on my peak hours :)

Share This Page