Saving virtuemart products painfully slow with lscache plugin enabled

Hi Ive encountered an issue with lscache, when we save products now, its taking about 10-15 seconds for the save. When I disable the lscache plugin it goes back to milliseconds.

can anyone help?
Joomla 3.10.11
Same issue for me.
Saving is ok, but it's the reload of the just saved page in backend that it take such a long time (up to 30 secs for somes)
I don't really remember, but I think this is since a particular rev of the lscache plugin.
If I find which one, I'ill edit this post.

And that's why I've made those comments too
And reported as an issue

But still no reply...

Last edited:

Wuhua Chen

Active Member
Staff member
I just replied webmastergreg's Github issue, there is no need to patch virturemart for the 3.2.2+ virturemart versions.

About the slow reload after save a product, it might because you enabled auto recache after saving feature in plugin settings, it will crawl all expired cache copy after saving a product or a category. if it is not that case, please submit a ticket or send your website information to .
Thanks Wuhua Chen.
I can confirm too, that the slow behaviour when saving is actually due to the recache option, so just disable it to avoid the phenomenon.
But it might be better if the recache process doesn't prevent you from regaining control of the product sheet being edited once saved, isn't recache supposed to be a process that can take place in the background?


Well-Known Member

This has nothing to do with the fact that a background process could solve the problem. The suspected cause is that the session and the data are locked as long as the recache process is not completed. This can be solved comparatively easily, but the plugin would have to be changed for this. I can't rule it out entirely, but it could also be Joomla itself and that will inevitably affect how the plugin works.


Well-Known Member
Unfortunately, I can only give you a limited explanation of the possible cause because I don't know the code of the plugin. But from the description of the problem, there is a lot to suggest that I'm right.