server won't respond after new account created

Discussion in 'Install/Configuration' started by aww, May 9, 2007.

  1. aww

    aww Well-Known Member

    I just tried to create a new account under cpanel to test some of the htaccess issues we have been talking about.

    After the account was created by cpanel I could no longer access any page or site on the server.

    Tried restarting lsws then the entire vps, no change.

    Redid the upgrade for 3.1.1 and tried a restart, it says it started with a pid but then no website access and I get this trying to access the admin console:

    Tried deleting lsws in /tmp without any change.

    Had to run Apache for now - which comes up without a problem.
  2. aww

    aww Well-Known Member

    Sorry again. My host hires absolute morons.
    I complained about a load spike, they saw lshttpd which they are not familiar with, so they disabled it without consulting me (this is a VPS, not a shared system)

    Absolutely idiots.

    Will be back later after I straighten this out.
  3. aww

    aww Well-Known Member

    Could you please tell me what to chmod and chown lsphp to?

    My host tampered with it's permissions and I don't what to to reset it back to.
  4. aww

    aww Well-Known Member

    Sigh, they made an absolute mess.
    Even after doing an upgrade there are still many files chmod'ed to 000.

    If I want to keep my configuration, what files do I need to copy off
    before I delete and re-install it? I also have ssl keys installed, can I save those?
  5. mistwang

    mistwang LiteSpeed Staff

    You can rename the old installation directory, then start from scratch. The old configuration files can be copied to your new installation.
  6. aww

    aww Well-Known Member

    I assume everything I have to worry about is in /admin/conf ?

    I also need /opt/lsws/php/php.ini ?

    Anything else?

    I actually got it up and running by deleting /lib and having it recreate the files, had to do the same for eaccellerator and re-installed that as well

    My apologies for so many posts and questions.
    My host really did me in with this nonsense.
    They actually thought lshttpd was a trojan/virus!

    I'm taking the opportunity to run lsws back on port 82 and comparing it more carefully to apache.

    By the way, open_basedir WAS working properly, in my apache php.ini I have error reporting turned on and in lsws's default php.ini it's turned off - so it wasn't reporting the issue.

    Thanks again for your help and patience.
    Last edited: May 9, 2007
  7. mistwang

    mistwang LiteSpeed Staff

    most configuration files are in lsws/conf directory. Should build your own PHP binary.

Share This Page